Re: Re: Re: i810 Audio driver=disabled

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<


Problem was: ... ASUS M2N Notebook ... I810_audio module did not get an IRQ and thus, is disabled.
Alan Cox wrote:
I believe this system needs an ACPI capable kernel for the audio to work
I tried Kernel 2.4.21 and 2.4.20-18.9 with ACPI compiled in (and APM out), but that did not help. I ran into more problems, as my USB mouse was not detected a.s.o., thus switched back to the RH provided 2.4.20-18.9.
I believe that the problem results from the ICH-4 controler module/driver. DMESG shows:
ICH4: chipset revision 3
ICH4: not 100% native mode: will probe irqs later
As fas as I know, ICH-4 includes IDE-controler, USB, Sound and other modules. Thus, if IRQs not probed properly, maybe sound was droped, while f.i. USB got one.
A piece of circumstantial evidence - IMHO - could be in the IRQ assignments posted already:
5: 1508 XT-PIC usb-uhci, usb-uhci, usb-uhci, ohci1394, eth0
Why share USB, FireWire and Eth0 the same IRQ ... while IRQ 9..11 are free at least?

Any ideas?


-- Sound-list mailing list Sound-list@xxxxxxxxxx

[Index of Archives]     [Sound Cards]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp Users]     [Yosemite Trails]

  Powered by Linux