Linux Kernel Memory Management
[Prev Page][Next Page]
- [PATCH] percpu: remove pcpu_alloc_size(), Jianhui Zhou
- [PATCH v4 00/10] support large folio swap-out and swap-in for shmem,
Baolin Wang
- [PATCH v4 01/10] mm: vmscan: add validation before spliting shmem large folio, Baolin Wang
- [PATCH v4 02/10] mm: swap: extend swap_shmem_alloc() to support batch SWAP_MAP_SHMEM flag setting, Baolin Wang
- [PATCH v4 03/10] mm: shmem: extend shmem_partial_swap_usage() to support large folio swap, Baolin Wang
- [PATCH v4 06/10] mm: shmem: use swap_free_nr() to free shmem swap entries, Baolin Wang
- [PATCH v4 07/10] mm: shmem: support large folio allocation for shmem_replace_folio(), Baolin Wang
- [PATCH v4 09/10] mm: shmem: split large entry if the swapin folio is not large, Baolin Wang
- [PATCH v4 05/10] mm: filemap: use xa_get_order() to get the swap entry order, Baolin Wang
- [PATCH v4 04/10] mm: shmem: return number of pages beeing freed in shmem_free_swap, Baolin Wang
- [PATCH v4 10/10] mm: shmem: support large folio swap out, Baolin Wang
- [PATCH v4 08/10] mm: shmem: drop folio reference count using 'nr_pages' in shmem_delete_from_page_cache(), Baolin Wang
- [PATCH v4 00/26] mm: introduce numa_memblks,
Mike Rapoport
- [PATCH v4 01/26] mm: move kernel/numa.c to mm/, Mike Rapoport
- [PATCH v4 05/26] MIPS: loongson64: rename __node_data to node_data, Mike Rapoport
- [PATCH v4 06/26] MIPS: loongson64: drop HAVE_ARCH_NODEDATA_EXTENSION, Mike Rapoport
- [PATCH v4 02/26] MIPS: sgi-ip27: make NODE_DATA() the same as on all other architectures, Mike Rapoport
- [PATCH v4 11/26] x86/numa: use get_pfn_range_for_nid to verify that node spans memory, Mike Rapoport
- [PATCH v4 04/26] MIPS: sgi-ip27: drop HAVE_ARCH_NODEDATA_EXTENSION, Mike Rapoport
- [PATCH v4 20/26] mm: numa_memblks: introduce numa_memblks_init, Mike Rapoport
- [PATCH v4 21/26] mm: numa_memblks: make several functions and variables static, Mike Rapoport
- [PATCH v4 14/26] x86/numa_emu: split __apicid_to_node update to a helper function, Mike Rapoport
- [PATCH v4 13/26] x86/numa_emu: simplify allocation of phys_dist, Mike Rapoport
- [PATCH v4 22/26] mm: numa_memblks: use memblock_{start,end}_of_DRAM() when sanitizing meminfo, Mike Rapoport
- [PATCH v4 03/26] MIPS: sgi-ip27: ensure node_possible_map only contains valid nodes, Mike Rapoport
- [PATCH v4 23/26] of, numa: return -EINVAL when no numa-node-id is found, Mike Rapoport
- [PATCH v4 08/26] mm: drop CONFIG_HAVE_ARCH_NODEDATA_EXTENSION, Mike Rapoport
- [PATCH v4 09/26] arch, mm: pull out allocation of NODE_DATA to generic code, Mike Rapoport
- [PATCH v4 26/26] docs: move numa=fake description to kernel-parameters.txt, Mike Rapoport
- [PATCH v4 12/26] x86/numa: move FAKE_NODE_* defines to numa_emu, Mike Rapoport
- [PATCH v4 15/26] x86/numa_emu: use a helper function to get MAX_DMA32_PFN, Mike Rapoport
- [PATCH v4 07/26] arch, mm: move definition of node_data to generic code, Mike Rapoport
- [PATCH v4 25/26] mm: make range-to-target_node lookup facility a part of numa_memblks, Mike Rapoport
- [PATCH v4 24/26] arch_numa: switch over to numa_memblks, Mike Rapoport
- [PATCH v4 17/26] mm: introduce numa_memblks, Mike Rapoport
- [PATCH v4 16/26] x86/numa: numa_{add,remove}_cpu: make cpu parameter unsigned, Mike Rapoport
- [PATCH v4 19/26] mm: introduce numa_emulation, Mike Rapoport
- [PATCH v4 10/26] x86/numa: simplify numa_distance allocation, Mike Rapoport
- [PATCH v4 18/26] mm: move numa_distance and related code from x86 to numa_memblks, Mike Rapoport
- [PATCH v2] mm: kfence: print the elapsed time for allocated/freed track,
qiwu.chen
- [PATCH -next v2] powerpc: Remove useless config comment in asm/percpu.h,
Jinjie Ruan
- [linux-next:master 3087/3348] arch/loongarch/kernel/machine_kexec.o: warning: objtool: kexec_shutdown_secondary+0x60: stack state mismatch: cfa1=3+0 cfa2=3+16, kernel test robot
- [linux-next:master 2649/3348] drivers/net/pse-pd/tps23881.c:755:6: error: call to undeclared function 'FIELD_GET'; ISO C99 and later do not support implicit function declarations, kernel test robot
- [PATCH] mm, slub: print CPU id on slab OOM,
Axel Rasmussen
- [PATCH 1/2] mm: update the memmap stat before page is freed,
Pasha Tatashin
- [PATCH v2 0/1] binfmt_elf: seal address zero,
jeffxu
- [rppt-memblock:for-next] BUILD SUCCESS 9e3d665384fca2a1c56283c7a79a968243ef4614, kernel test robot
- [PATCH 0/7] mm: Optimize mseal checks,
Pedro Falcato
- [v6.6-stable PATCH] mm: gup: stop abusing try_grab_folio,
Yang Shi
- [linux-next:fs-next] BUILD SUCCESS d15fe7f84765bc7905e3128bfbce964e5b77164e, kernel test robot
- [linux-next:master 3152/3348] kernel/resource.c:1246:undefined reference to `devmem_is_allowed', kernel test robot
- [linux-next:master 3152/3348] arm-linux-gnueabi-ld: drivers/char/mem.c:62:undefined reference to `devmem_is_allowed', kernel test robot
- [linux-next:master] BUILD REGRESSION 1e391b34f6aa043c7afa40a2103163a0ef06d179, kernel test robot
- [PATCH v3] binfmt_elf: Dump smaller VMAs first in ELF cores,
Brian Mak
- [PATCH v2] mm/memory-failure: Use raw_spinlock_t in struct memory_failure_cpu,
Waiman Long
- Warning on mremapped uffd-wp memory,
Ryan Roberts
- [linux-next:pending-fixes] BUILD SUCCESS e1a15959d75c9ba4b45e07e37bcf843c85750010, kernel test robot
- [linux-next:master] [fs] cdc4ad36a8: kernel_BUG_at_include/linux/page-flags.h,
kernel test robot
- [PATCH] mm/memory-failure: Use raw_spinlock_t in struct memory_failure_cpu,
Waiman Long
- [linux-next:fs-current] BUILD SUCCESS ba2e1663436dc16a86ed31d5f7adb173dc7d02d6, kernel test robot
- [PATCH v5] rust: mm: add abstractions for mm_struct and vm_area_struct, Alice Ryhl
- Re: [PATCH 5/8] mm: Add a helper to accept page, David Hildenbrand
- Re: [PATCH 4/8] mm: Rename accept_page() to accept_page_memory(), David Hildenbrand
- Re: [PATCH 3/8] mm: Introduce PageUnaccepted() page type,
David Hildenbrand
- Re: [PATCH 1/8] mm: Fix endless reclaim on machines with unaccepted memory, David Hildenbrand
- [PATCH -next] powerpc: Fix a config comment typo in asm/percpu.h,
Jinjie Ruan
- [linux-next:master 2827/3348] mm/numa_memblks.c:427:31: warning: implicit conversion from 'unsigned long long' to 'phys_addr_t' (aka 'unsigned int') changes value from 18446744073709551615 to 4294967295, kernel test robot
- [linux-next:master 2333/3348] arch/arm64/boot/dts/renesas/r9a08g045s33-smarc.dtb: dma-controller@11820000: compatible:0: 'renesas,r9a08g045-dmac' is not one of ['renesas,r9a07g043-dmac', 'renesas,r9a07g044-dmac', 'renesas,r9a07g054-dmac'], kernel test robot
- shmem folio changes have broken linux-next,
Ryan Roberts
- Re: [PATCH 2/8] mm: Accept memory in __alloc_pages_bulk().,
Mike Rapoport
- Re: [PATCH] md/raid6 algorithms: scale test duration for speedier boots,
kernel test robot
- Re: [PATCH 6.10 000/809] 6.10.3-rc3 review,
Linus Torvalds
Re: [PATCH 6.10 000/809] 6.10.3-rc3 review, Guenter Roeck
[RFC PATCH 0/4] mm/arm64: re-enable HVO,
Yu Zhao
[PATCH v5 00/21] mm/zsmalloc: add zpdesc memory descriptor for zswap.zpool,
alexs
- [PATCH v5 00/21] mm/zsmalloc: add zpdesc memory descriptor for zswap.zpool, alexs
- [PATCH v5 02/21] mm/zsmalloc: use zpdesc in trylock_zspage()/lock_zspage(), alexs
- [PATCH v5 03/21] mm/zsmalloc: convert __zs_map_object/__zs_unmap_object to use zpdesc, alexs
- [PATCH v5 04/21] mm/zsmalloc: add and use pfn/zpdesc seeking funcs, alexs
- [PATCH v5 06/21] mm/zsmalloc: convert create_page_chain() and its users to use zpdesc, alexs
- [PATCH v5 11/21] mm/zsmalloc: rename reset_page to reset_zpdesc and use zpdesc in it, alexs
- [PATCH v5 08/21] mm/zsmalloc: convert init_zspage() to use zpdesc, alexs
- [PATCH v5 13/21] mm/zsmalloc: convert location_to_obj() to take zpdesc, alexs
- [PATCH v5 12/21] mm/zsmalloc: convert __free_zspage() to use zdsesc, alexs
- [PATCH v5 14/21] mm/zsmalloc: convert migrate_zspage() to use zpdesc, alexs
- [PATCH v5 15/21] mm/zsmalloc: convert get_zspage() to take zpdesc, alexs
- [PATCH v5 05/21] mm/zsmalloc: convert obj_malloc() to use zpdesc, alexs
- [PATCH v5 01/21] mm/zsmalloc: add zpdesc memory descriptor for zswap.zpool, alexs
- [PATCH v5 09/21] mm/zsmalloc: convert obj_to_page() and zs_free() to use zpdesc, alexs
- [PATCH v5 18/21] mm/zsmalloc: introduce __zpdesc_clear_movable, alexs
- [PATCH v5 19/21] mm/zsmalloc: introduce __zpdesc_clear/set_zsmalloc(), alexs
- [PATCH v5 10/21] mm/zsmalloc: add zpdesc_is_isolated()/zpdesc_zone() helper for zs_page_migrate(), alexs
- [PATCH v5 21/21] mm/zsmalloc: update comments for page->zpdesc changes, alexs
- [PATCH v5 16/21] mm/zsmalloc: convert SetZsPageMovable and remove unused funcs, alexs
- [PATCH v5 20/21] mm/zsmalloc: introduce zpdesc_clear_first() helper, alexs
- [PATCH v5 17/21] mm/zsmalloc: convert get/set_first_obj_offset() to take zpdesc, alexs
- [PATCH v5 07/21] mm/zsmalloc: convert obj_allocated() and related helpers to use zpdesc, alexs
- Re: [PATCH v5 00/21] mm/zsmalloc: add zpdesc memory descriptor for zswap.zpool, Andrew Morton
[PATCH] mm: attempt to batch free swap entries for zap_pte_range(),
Barry Song
[PATCH v4 1/5] memblock test: fix implicit declaration of function 'virt_to_phys',
Wei Yang
[PATCH v3 0/2] improving dynamic zswap shrinker protection scheme,
Nhat Pham
[linux-next:fs-current] BUILD SUCCESS a30bdcb59da63bfa89f6d03dbf4d17a6d747c1f0, kernel test robot
[PATCH net-next v18 06/14] page_pool: devmem support, Mina Almasry
[akpm-mm:mm-unstable 173/179] include/vdso/limits.h:16:25: warning: conversion from 'long long unsigned int' to 'phys_addr_t' {aka 'unsigned int'} changes value from '18446744073709551615' to '4294967295', kernel test robot
[linux-next:master] BUILD REGRESSION d6dbc9f56c3a70e915625b6f1887882c23dc5c91, kernel test robot
[linux-next:fs-next] BUILD SUCCESS b6b3ab6bae73b8ba1fefadea42f448f27591365b, kernel test robot
[RFC PATCH 0/3] Enable strict percpu address space checks,
Uros Bizjak
[PATCH RFC 0/4] mm: Introduce guest_memfd library,
Elliot Berman
Re: [PATCH 7/8] mm: Introduce promo_wmark_pages(),
Johannes Weiner
[PATCH 1/4] mm/mempolicy: Use folio_alloc_mpol_noprof() in alloc_pages_noprof(),
Aruna Ramakrishna
[PATCH] mm: swap: mTHP frees entries as a whole,
Zhiguo Jiang
[linux-next:master 568/3069] drivers/gpu/drm/xe/xe_migrate.c:304:52: error: result of comparison of constant 274877906944 with expression of type 'resource_size_t' (aka 'unsigned int') is always true, kernel test robot
[PATCH v3 0/2] mm: tlb swap entries batch async release,
Zhiguo Jiang
[PATCH v4 00/28] Generic `Allocator` support for Rust,
Danilo Krummrich
- [PATCH v4 01/28] rust: alloc: add `Allocator` trait, Danilo Krummrich
- [PATCH v4 02/28] rust: alloc: separate `aligned_size` from `krealloc_aligned`, Danilo Krummrich
- [PATCH v4 03/28] rust: alloc: rename `KernelAllocator` to `Kmalloc`, Danilo Krummrich
- [PATCH v4 05/28] rust: alloc: add module `allocator_test`, Danilo Krummrich
- [PATCH v4 18/28] rust: treewide: switch to the kernel `Vec` type, Danilo Krummrich
- [PATCH v4 17/28] rust: alloc: implement `collect` for `IntoIter`, Danilo Krummrich
- [PATCH v4 20/28] rust: alloc: add `Vec` to prelude, Danilo Krummrich
- [PATCH v4 19/28] rust: alloc: remove `VecExt` extension, Danilo Krummrich
- [PATCH v4 11/28] rust: alloc: remove `BoxExt` extension, Danilo Krummrich
- [PATCH v4 04/28] rust: alloc: implement `Allocator` for `Kmalloc`, Danilo Krummrich
- [PATCH v4 22/28] rust: error: use `core::alloc::LayoutError`, Danilo Krummrich
- [PATCH v4 23/28] rust: error: check for config `test` in `Error::name`, Danilo Krummrich
- [PATCH v4 14/28] rust: alloc: import kernel `Box` type in init.rs, Danilo Krummrich
- [PATCH v4 09/28] rust: alloc: implement kernel `Box`, Danilo Krummrich
- [PATCH v4 07/28] rust: alloc: implement `KVmalloc` allocator, Danilo Krummrich
- [PATCH v4 13/28] rust: alloc: import kernel `Box` type in types.rs, Danilo Krummrich
- [PATCH v4 27/28] rust: alloc: update module comment of alloc.rs, Danilo Krummrich
- [PATCH v4 06/28] rust: alloc: implement `Vmalloc` allocator, Danilo Krummrich
- [PATCH v4 21/28] rust: alloc: remove `GlobalAlloc` and `krealloc_aligned`, Danilo Krummrich
- [PATCH v4 08/28] rust: types: implement `Unique<T>`, Danilo Krummrich
[PATCH v4 12/28] rust: alloc: add `Box` to prelude, Danilo Krummrich
[PATCH v4 16/28] rust: alloc: implement `IntoIterator` for `Vec`, Danilo Krummrich
[PATCH v4 28/28] kbuild: rust: remove the `alloc` crate, Danilo Krummrich
[PATCH v4 25/28] rust: alloc: implement `Cmalloc` in module allocator_test, Danilo Krummrich
[PATCH v4 15/28] rust: alloc: implement kernel `Vec` type, Danilo Krummrich
[PATCH v4 26/28] rust: str: test: replace `alloc::format`, Danilo Krummrich
[PATCH v4 24/28] rust: alloc: implement `contains` for `Flags`, Danilo Krummrich
[PATCH v4 10/28] rust: treewide: switch to our kernel `Box` type, Danilo Krummrich
[RFC PATCH v2 0/7] synchronously scan and reclaim empty user PTE pages,
Qi Zheng
[PATCH] mm: fix (harmless) type confusion in lock_vma_under_rcu(),
Jann Horn
[PATCH] kfence: introduce burst mode,
Marco Elver
[PATCH 00/10] mm: remove vma_merge(),
Lorenzo Stoakes
- [PATCH 01/10] tools: improve vma test Makefile, Lorenzo Stoakes
- [PATCH 03/10] mm: abstract duplicated policy comparison, Lorenzo Stoakes
- [PATCH 04/10] mm: abstract parameters for vma_expand/shrink(), Lorenzo Stoakes
- [PATCH 07/10] mm: avoid using vma_merge() for new VMAs, Lorenzo Stoakes
- [PATCH 06/10] tools: add VMA merge tests, Lorenzo Stoakes
- [PATCH 02/10] mm: introduce vma_merge_struct and abstract merge parameters, Lorenzo Stoakes
- [PATCH 05/10] mm: abstract vma_merge_new_vma() to use vma_merge_struct, Lorenzo Stoakes
- [PATCH 10/10] mm: rework vm_ops->close() handling on VMA merge, Lorenzo Stoakes
- [PATCH 08/10] mm: introduce commit_merge(), abstracting merge operation, Lorenzo Stoakes
- [PATCH 09/10] mm: refactor vma_merge() into modify-only vma_merge_modified(), Lorenzo Stoakes
[linux-next:master /3069] ERROR: modpost: "tpm2_sessions_init" [drivers/char/tpm/tpm_ibmvtpm.ko] undefined!, kernel test robot
[PATCH v2 2/2] lib/htree: Modified Documentation/core-api/htree.rst, JaeJoon Jung
[PATCH v2 1/2] lib/htree: Add locking interface to new Hash Tree,
JaeJoon Jung
[GIT PULL] slab fixes for 6.11-rc2,
Vlastimil Babka
[PATCH 00/10] Introduce guestmemfs: persistent in-memory filesystem,
James Gowans
- [PATCH 02/10] guestmemfs: add inode store, files and dirs, James Gowans
- [PATCH 03/10] guestmemfs: add persistent data block allocator, James Gowans
- [PATCH 05/10] guestmemfs: add file mmap callback, James Gowans
- [PATCH 04/10] guestmemfs: support file truncation, James Gowans
- [PATCH 01/10] guestmemfs: Introduce filesystem skeleton, James Gowans
- [PATCH 06/10] kexec/kho: Add addr flag to not initialise memory, James Gowans
- [PATCH 07/10] guestmemfs: Persist filesystem metadata via KHO, James Gowans
- [PATCH 08/10] guestmemfs: Block modifications when serialised, James Gowans
- [PATCH 10/10] MAINTAINERS: Add maintainers for guestmemfs, James Gowans
- [PATCH 09/10] guestmemfs: Add documentation and usage instructions, James Gowans
- Re: [PATCH 00/10] Introduce guestmemfs: persistent in-memory filesystem, Theodore Ts'o
- Re: [PATCH 00/10] Introduce guestmemfs: persistent in-memory filesystem, Jan Kara
- Re: [PATCH 00/10] Introduce guestmemfs: persistent in-memory filesystem, David Matlack
- Re: [PATCH 00/10] Introduce guestmemfs: persistent in-memory filesystem, Vishal Annapurve
[Index of Archives]
[Linux Kernel Development]
[Linux ARM Kernel]
[Linux MIPS]
[Linux S390]
[Bugtraq]
[Fedora ARM]