Re: [PATCH 3/9] x86: vdso: Introduce asm/vdso/page.h

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




On 04/09/2024 16:05, Christophe Leroy wrote:
> 
> 
> Le 04/09/2024 à 16:52, Arnd Bergmann a écrit :
>> On Tue, Sep 3, 2024, at 15:14, Vincenzo Frascino wrote:
>>
...

>>> +
>>> +#ifndef __ASSEMBLY__
>>> +
>>> +#include <asm/page_types.h>
>>> +
>>> +#define VDSO_PAGE_MASK    PAGE_MASK
>>> +#define VDSO_PAGE_SIZE    PAGE_SIZE
>>> +
>>> +#endif /* !__ASSEMBLY__ */
>>> +
>>> +#endif /* __ASM_VDSO_PAGE_H */
>>
>> I don't get this one: the x86 asm/page_types.h still includes other
>> headers outside of the vdso namespace, but you seem to only need these
>> two definitions that are the same across everything.
>>
>> Why not put PAGE_MASK and PAGE_SIZE into a global vdso/page.h
>> header? I did spend a lot of time a few months ago ensuring that
>> we can have a single definition for all architectures based on
>> CONFIG_PAGE_SHIFT, so all the extra copies should just go away.
>>
> 
> Just wondering, after looking at x86, powerpc and arm64, is there any difference
> between:
> 
> X86,ARM64:
> #define PAGE_SIZE        (_AC(1,UL) << PAGE_SHIFT)
> #define PAGE_MASK        (~(PAGE_SIZE-1))
> 
> POWERPC:
> #define PAGE_SIZE        (ASM_CONST(1) << PAGE_SHIFT)
> /*
>  * Subtle: (1 << PAGE_SHIFT) is an int, not an unsigned long. So if we
>  * assign PAGE_MASK to a larger type it gets extended the way we want
>  * (i.e. with 1s in the high bits)
>  */
> #define PAGE_MASK      (~((1 << PAGE_SHIFT) - 1))
> 
> 
> Which one should be taken in vdso/page.h ?
>

I am not sure either on this point. That's the main reason why I proposed an
indirection for the definitions.

> Christophe

-- 
Regards,
Vincenzo




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux