On 12/05/2008 09:49 PM, Łukasz Lubojański wrote: > Because the module supports only the FF now - I have changed module > name to hid-gaff. ------=_Part_46985_7823613.1228510186768 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: base64 Content-Disposition: inline :( +#define debug(format, arg...) pr_debug("hid-gaff: " format "\n" , ## arg) You don't need yet another pr_debug wrapper, use dev_dbg instead all over the code. I would call the hid driver "hid-gaff" and won't add this to every print -- dev_* calls will do it on their own. +static int ga_init(void) mark as __init +static void ga_exit(void) mark as __exit Otherwise looks good! -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html