Re: piping escape into dosemu

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Thanks all for your effort to help me!  I accidentally didn't reply to
the list, so here it is again:

2010/3/11 Alain Mouette <alainm@xxxxxxxxx>:
> To make sure that it works allways the same, use explicit external:
> $ /bin/echo -ne "\033" | od -x
> 0000000 001b
> 0000001

It does.

So back to my original problem:  I want to achieve the same effect
that I can with

  dosemu -input 'thedosapp.exe\r\^['

The actual byte sequence that sh passes to dosemu as argument after -input is

  74 68 65 64 6f 73 61 70 70 2e 65 78 65 5c 72 5c 1b

I can get the exact same byte sequence with

  /bin/echo -n 'thedosapp.exe\r\['

For the keystroke command that's piped I need a newline at the end, so
I omit -n and use

  /bin/echo 'keystroke thedosapp.exe\r\^[' > dospipe

Everything gets through except for the ESC.  I guess this is the end
of the song.

Alain suggested later:

2010/3/11 Alain Mouette <alainm@xxxxxxxxx>:
> Have you tried using 2 ESCs ? maybe you get one at the other ent... this
> happens so many linux programas...

Unfortunately still no success.  I suspect the string that's piped is
parsed somewhat differently from the string that's passed on the
command line, and this can only be fixed in the source code.

Thomas Weber
To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux