Linux Arch
[Prev Page][Next Page]
- [RFC PATCH v3 08/19] smp, IA64: kill SMP single function call interrupt, (continued)
- [RFC PATCH v3 08/19] smp, IA64: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 07/19] smp, hexagon: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 05/19] smp, ARM64: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 09/19] smp, m32r: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 04/19] smp, ARM: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 03/19] smp, alpha: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 02/19] Revert "smp: Fix SMP function call empty cpu mask race", Jiang Liu
- [RFC PATCH v3 11/19] smp, mn10300: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 10/19] smp, metag: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 12/19] smp, mn10300: enable arch_send_call_function_ipi_mask(), Jiang Liu
- [RFC PATCH v3 13/19] smp, s390: prepare for killing generic_smp_call_function_single_interrupt(), Jiang Liu
- [RFC PATCH v3 14/19] smp, sh: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 15/19] smp, sparc64: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 16/19] smp, sparc: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 17/19] smp, tile: kill SMP single function call interrupt, Jiang Liu
- Re: [RFC PATCH v3 00/19] simplify generic cross CPU function call implementation, Christoph Hellwig
- [RFC PATCH v3 18/19] smp, tile: kill SMP single function call interrupt, Jiang Liu
- [RFC PATCH v3 19/19] smp, x86: kill SMP single function call interrupt, Jiang Liu
- [PATCH v3 00/17] xtensa SMP queue update,
Max Filippov
- [PATCH] arch: include/asm/Kbuild: fix preempt.h sort order,
James Hogan
- [PATCH 0/4] generic early_ioremap support,
Mark Salter
- Re: ARM: add support to dump the kernel page tables, Uwe Kleine-König
- [PATCH v2 00/11] Consolidate asm/fixmap.h files,
Mark Salter
- Preventing IPI sending races in arch code,
Vineet Gupta
- [PATCH 0024] asm-generic: Rename int-ll64.h to types.h,
Geert Uytterhoeven
- [PATCH 14/24] avr32: Use Kbuild logic to provide <asm/types.h>, Geert Uytterhoeven
- [PATCH 15/24] cris: Use Kbuild logic to provide <asm/types.h>, Geert Uytterhoeven
- [PATCH 23/24] xtensa: Separate kernel/userspace inclusion of <asm-generic/int-ll64.h>, Geert Uytterhoeven
- [PATCH 20/24] xtensa: Remove duplicate definition of BITS_PER_LONG, Geert Uytterhoeven
- [PATCH 12/24] alpha: Remove #include <uapi/asm/types.h> from <asm/types.h>, Geert Uytterhoeven
- [PATCH 24/24] asm-generic: Rename int-ll64.h to types.h, Geert Uytterhoeven
- [PATCH 03/24] cris/uapi: Use Kbuild logic to provide <asm/types.h>, Geert Uytterhoeven
- [PATCH 08/24] parisc/uapi: Use Kbuild logic to provide <asm/types.h>, Geert Uytterhoeven
- [PATCH 18/24] mn10300: Use Kbuild logic to provide <asm/types.h>, Geert Uytterhoeven
- [PATCH 04/24] frv/uapi: Use Kbuild logic to provide <asm/types.h>, Geert Uytterhoeven
- [PATCH 19/24] sh: Replace <uapi/asm/types.h> by <asm-generic/int-ll64.h>, Geert Uytterhoeven
- [PATCH 21/24] powerpc: Separate kernel/userspace inclusion of <asm-generic/int-ll64.h>, Geert Uytterhoeven
- [PATCH 06/24] microblaze/uapi: Use Kbuild logic to include <asm-generic/types.h>, Geert Uytterhoeven
- [PATCH 16/24] frv: Use Kbuild logic to provide <asm/types.h>, Geert Uytterhoeven
- [PATCH 22/24] s390: Separate kernel/userspace inclusion of <asm-generic/int-ll64.h>, Geert Uytterhoeven
- [PATCH 17/24] m32r: Use Kbuild logic to provide <asm/types.h>, Geert Uytterhoeven
- [PATCH 10/24] sh/uapi: Use Kbuild logic to include <asm-generic/types.h>, Geert Uytterhoeven
- [PATCH 09/24] score/uapi: Use Kbuild logic to include <asm-generic/types.h>, Geert Uytterhoeven
- [PATCH 13/24] mips: Remove #include <uapi/asm/types.h> from <asm/types.h>, Geert Uytterhoeven
- [PATCH 07/24] mn10300/uapi: Use Kbuild logic to provide <asm/types.h>, Geert Uytterhoeven
- [PATCH 01/24] uapi: Add missing _UAPI prefix to <asm-generic/types.h> include guard, Geert Uytterhoeven
- [PATCH 11/24] x86/uapi: Use Kbuild logic to include <asm-generic/types.h>, Geert Uytterhoeven
- [PATCH 02/24] avr32/uapi: Use Kbuild logic to provide <asm/types.h>, Geert Uytterhoeven
- [PATCH 05/24] m32r/uapi: Use Kbuild logic to provide <asm/types.h>, Geert Uytterhoeven
- Re: [PATCH 0024] asm-generic: Rename int-ll64.h to types.h, James Bottomley
- [PATCH v7 0/4] qrwlock: Introducing a queue read/write lock implementation,
Waiman Long
- [RFC] Control dependencies,
Peter Zijlstra
- [PATCH v2] of: unflatten_and_copy: handle NULL initial_boot_params,
James Hogan
- Re: [PATCH v2] arch: use ASM_NL instead of ';' for assembler new line character in the macro,
Vineet Gupta
- Re: [patch 4/6] ia64: Use preempt_schedule_irq,
Tony Luck
- Re: [PATCH 34/34] mm: dynamically allocate page->ptl if it cannot be embedded to struct page,
Andrey Wagin
- [PATCH -tip v3 00/23] kprobes: introduce NOKPROBE_SYMBOL() and general cleaning of kprobe blacklist,
Masami Hiramatsu
- [PATCH -tip v3 03/23] kprobes: Show blacklist entries via debugfs, Masami Hiramatsu
- [PATCH -tip v3 04/23] kprobes: Support blacklist functions in module, Masami Hiramatsu
- [PATCH -tip v3 08/23] kprobes: Allow probe on some kprobe functions, Masami Hiramatsu
- [PATCH -tip v3 05/23] kprobes: Use NOKPROBE_SYMBOL() in sample modules, Masami Hiramatsu
- [PATCH -tip v3 01/23] kprobes: Prohibit probing on .entry.text code, Masami Hiramatsu
- [PATCH -tip v3 12/23] x86/hw_breakpoint: Use NOKPROBE_SYMBOL macro in hw_breakpoint, Masami Hiramatsu
- [PATCH -tip v3 16/23] x86/nmi: Use NOKPROBE_SYMBOL macro for nmi handlers, Masami Hiramatsu
- [PATCH -tip v3 06/23] kprobes/x86: Allow probe on some kprobe preparation functions, Masami Hiramatsu
- [PATCH -tip v3 14/23] x86/fault: Use NOKPROBE_SYMBOL macro in fault.c, Masami Hiramatsu
- [PATCH -tip v3 07/23] kprobes/x86: Use NOKPROBE_SYMBOL instead of __kprobes, Masami Hiramatsu
- [PATCH -tip v3 17/23] x86/kvm: Use NOKPROBE_SYMBOL macro in kvm.c, Masami Hiramatsu
- [PATCH -tip v3 10/23] ftrace/kprobes: Allow probing on some preparation functions, Masami Hiramatsu
- [PATCH -tip v3 22/23] sched: Use NOKPROBE_SYMBOL macro in sched, Masami Hiramatsu
- [PATCH -tip v3 23/23] kprobes/x86: Use kprobe_blacklist for .kprobes.text and .entry.text, Masami Hiramatsu
- [PATCH -tip v3 21/23] notifier: Use NOKPROBE_SYMBOL macro in notifier, Masami Hiramatsu
- [PATCH -tip v3 20/23] [BUGFIX] kprobes: Prohibit probing on func_ptr_is_kernel_text, Masami Hiramatsu
- [PATCH -tip v3 19/23] [BUGFIX] kprobes/x86: Prohibit probing on debug_stack_*, Masami Hiramatsu
- [PATCH -tip v3 18/23] x86/dumpstack: Use NOKPROBE_SYMBOL macro in dumpstack.c, Masami Hiramatsu
- [PATCH -tip v3 13/23] x86/trap: Use NOKPROBE_SYMBOL macro in trap.c, Masami Hiramatsu
- [PATCH -tip v3 15/23] x86/alternative: Use NOKPROBE_SYMBOL macro in alternative.c, Masami Hiramatsu
- [PATCH -tip v3 09/23] kprobes: Use NOKPROBE_SYMBOL macro instead of __kprobes, Masami Hiramatsu
- [PATCH -tip v3 02/23] kprobes: Introduce NOKPROBE_SYMBOL() macro for blacklist, Masami Hiramatsu
- [PATCH -tip v3 11/23] ftrace/kprobes: Use NOKPROBE_SYMBOL macro in ftrace, Masami Hiramatsu
- Re: [PATCH -tip v3 00/23] kprobes: introduce NOKPROBE_SYMBOL() and general cleaning of kprobe blacklist, Frank Ch. Eigler
- [PATCH v6 3/5] MCS Lock: Move mcs_lock/unlock function into its own file, Tim Chen
- [PATCH v6 4/5] MCS Lock: Barrier corrections,
Tim Chen
- [PATCH v6 5/5] MCS Lock: Allows for architecture specific mcs lock and unlock, Tim Chen
- [PATCH v6 2/5] MCS Lock: optimizations and extra comments, Tim Chen
- [PATCH v6 1/5] MCS Lock: Restructure the MCS lock defines and locking code into its own file, Tim Chen
- [PATCH v6 0/5] MCS Lock: MCS lock code cleanup and optimizations, Tim Chen
- [PATCH v2 0/3] get/set_dumpable() cleanups and theoretical fix,
Oleg Nesterov
- [PATCH] of: unflatten_and_copy: handle NULL initial_boot_params,
James Hogan
- [PATCH RESEND] asm/types.h: Remove include/asm-generic/int-l64.h,
Geert Uytterhoeven
- Re: [PATCH 00/17] xtensa SMP queue,
Chris Zankel
- Re: [patch 05/34] idle: Implement generic idle function,
Viresh Kumar
- [PATCH 0/3] get/set_dumpable() cleanups and theoretical fix,
Oleg Nesterov
- [PATCH -tip RFC v2 00/22] kprobes: introduce NOKPROBE_SYMBOL() and general cleaning of kprobe blacklist,
Masami Hiramatsu
- [PATCH -tip RFC v2 12/22] x86/hw_breakpoint: Use NOKPROBE_SYMBOL macro in hw_breakpoint, Masami Hiramatsu
- [PATCH -tip RFC v2 09/22] kprobes: Use NOKPROBE_SYMBOL macro instead of __kprobes, Masami Hiramatsu
- [PATCH -tip RFC v2 04/22] kprobes: Support blacklist functions in module, Masami Hiramatsu
- [PATCH -tip RFC v2 07/22] kprobes/x86: Use NOKPROBE_SYMBOL instead of __kprobes, Masami Hiramatsu
- [PATCH -tip RFC v2 17/22] x86/kvm: Use NOKPROBE_SYMBOL macro in kvm.c, Masami Hiramatsu
- [PATCH -tip RFC v2 22/22] sched: Use NOKPROBE_SYMBOL macro in sched, Masami Hiramatsu
- [PATCH -tip RFC v2 11/22] ftrace/kprobes: Use NOKPROBE_SYMBOL macro in ftrace, Masami Hiramatsu
- [PATCH -tip RFC v2 01/22] kprobes: Prohibit probing on .entry.text code, Masami Hiramatsu
- [PATCH -tip RFC v2 02/22] kprobes: Introduce NOKPROBE_SYMBOL() macro for blacklist, Masami Hiramatsu
- [PATCH -tip RFC v2 21/22] notifier: Use NOKPROBE_SYMBOL macro in notifier, Masami Hiramatsu
- [PATCH -tip RFC v2 13/22] x86/trap: Use NOKPROBE_SYMBOL macro in trap.c, Masami Hiramatsu
- [PATCH -tip RFC v2 10/22] ftrace/kprobes: Allow probing on some preparation functions, Masami Hiramatsu
- [PATCH -tip RFC v2 08/22] kprobes: Allow probe on some kprobe functions, Masami Hiramatsu
- [PATCH -tip RFC v2 18/22] x86/dumpstack: Use NOKPROBE_SYMBOL macro in dumpstack.c, Masami Hiramatsu
- [PATCH -tip RFC v2 16/22] x86/nmi: Use NOKPROBE_SYMBOL macro for nmi handlers, Masami Hiramatsu
- [PATCH -tip RFC v2 03/22] kprobes: Show blacklist entries via debugfs, Masami Hiramatsu
- [PATCH -tip RFC v2 06/22] kprobes/x86: Allow probe on some kprobe preparation functions, Masami Hiramatsu
- [PATCH -tip RFC v2 19/22] [BUGFIX] kprobes/x86: Prohibit probing on debug_stack_*, Masami Hiramatsu
- [PATCH -tip RFC v2 20/22] [BUGFIX] kprobes: Prohibit probing on func_ptr_is_kernel_text, Masami Hiramatsu
- [PATCH -tip RFC v2 15/22] x86/alternative: Use NOKPROBE_SYMBOL macro in alternative.c, Masami Hiramatsu
- [PATCH -tip RFC v2 05/22] kprobes: Use NOKPROBE_SYMBOL() in sample modules, Masami Hiramatsu
- [PATCH -tip RFC v2 14/22] x86/fault: Use NOKPROBE_SYMBOL macro in fault.c, Masami Hiramatsu
- [PATCH 00/17] <asm/sections.h> related cleanups,
Geert Uytterhoeven
- [PATCH 07/17] ia64: Remove duplicate declarations of __per_cpu_start[] and __per_cpu_end[], Geert Uytterhoeven
- [PATCH 06/17] frv: Remove unused declarations of __start___ex_table and __stop___ex_table, Geert Uytterhoeven
- [PATCH RFC 16/17] c6x: Convert from _fdt_start to __dtb_start, Geert Uytterhoeven
- [PATCH 03/17] m32r: Use Kbuild logic to include <asm-generic/sections.h>, Geert Uytterhoeven
- [PATCH 11/17] kernel/param: Consolidate __{start,stop}___param[] in <linux/moduleparam.h>, Geert Uytterhoeven
- [PATCH 10/17] tile: Remove tile-specific _sinitdata and _einitdata, Geert Uytterhoeven
- [PATCH RFC 15/17] microblaze: Convert from _fdt_start to __dtb_start, Geert Uytterhoeven
- [PATCH 08/17] microblaze: Remove _fdt_start casts, Geert Uytterhoeven
- [PATCH 12/17] nosave: Consolidate __nosave_{begin,end} in <asm/sections.h>, Geert Uytterhoeven
- [PATCH 13/17] openrisc: Refactor or32_early_setup(), Geert Uytterhoeven
- [PATCH 09/17] microblaze: Remove duplicate declarations of _stext[] and _etext[], Geert Uytterhoeven
- [PATCH 02/17] cris: Use Kbuild logic to include <asm-generic/sections.h>, Geert Uytterhoeven
- [PATCH 01/17] alpha: Use Kbuild logic to include <asm-generic/sections.h>, Geert Uytterhoeven
- [PATCH 17/17] um: Remove unused declarations from <as-layout.h>, Geert Uytterhoeven
- [PATCH 04/17] mn10300: Use Kbuild logic to include <asm-generic/sections.h>, Geert Uytterhoeven
- [PATCH 14/17] dt: Consolidate __dtb_start declarations in <linux/of_fdt.h>, Geert Uytterhoeven
- Re: [PATCH 14/17] dt: Consolidate __dtb_start declarations in <linux/of_fdt.h>, Vineet Gupta
- Re: [PATCH 14/17] dt: Consolidate __dtb_start declarations in <linux/of_fdt.h>, Rob Herring
- Re: [PATCH 14/17] dt: Consolidate __dtb_start declarations in <linux/of_fdt.h>, Geert Uytterhoeven
- [PATCH 1/9] dt: Handle passed/built-in DT selection in early_init_dt_scan(), Geert Uytterhoeven
- [PATCH 2/9] arc: Use NULL as the default DTB, Geert Uytterhoeven
- [PATCH 3/9] c6x: Remove duplicate DT selection logic, Geert Uytterhoeven
- [PATCH 8/9] openrisc: Remove duplicate DT selection logic, Geert Uytterhoeven
- [PATCH 5/9] microblaze: Use NULL as the default DTB, Geert Uytterhoeven
- [PATCH 4/9] metag: Remove duplicate DT selection logic, Geert Uytterhoeven
- [PATCH 9/9] xtensa: Use NULL as the default DTB, Geert Uytterhoeven
- [PATCH 6/9] mips: Remove unused dt_setup_arch(), Geert Uytterhoeven
- [PATCH 7/9] mips: Use NULL as the default DTB, Geert Uytterhoeven
- Re: [PATCH 1/9] dt: Handle passed/built-in DT selection in early_init_dt_scan(), James Hogan
- Re: [PATCH 1/9] dt: Handle passed/built-in DT selection in early_init_dt_scan(), Rob Herring
- Re: [PATCH 1/9] dt: Handle passed/built-in DT selection in early_init_dt_scan(), Grant Likely
- Re: [PATCH 14/17] dt: Consolidate __dtb_start declarations in <linux/of_fdt.h>, James Hogan
- [PATCH 05/17] score: Use Kbuild logic to include <asm-generic/sections.h>, Geert Uytterhoeven
- Re: [PATCH 00/17] <asm/sections.h> related cleanups, Geert Uytterhoeven
- [PATCH 1/2] openrisc: Use the declarations provided by <asm/sections.h>, Geert Uytterhoeven
- Re: [PATCH 00/17] <asm/sections.h> related cleanups, Vineet Gupta
- Re: [PATCH 06/17] frv: Remove unused declarations of __start___ex_table and __stop___ex_table, David Howells
- Re: [PATCH 04/17] mn10300: Use Kbuild logic to include <asm-generic/sections.h>, David Howells
- [PATCH 01/14] ARC: locks: remove redundant arch_*_relax operations,
Will Deacon
- [PATCH 03/14] arm64: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 02/14] ARM: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 08/14] metag: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 13/14] sparc: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 09/14] mips: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 06/14] ia64: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 11/14] s390: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 10/14] hppa: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 05/14] cris: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 14/14] x86: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 04/14] blackfin: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 12/14] sh: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH 07/14] m32r: locks: remove redundant arch_*_relax operations, Will Deacon
- Re: [PATCH 01/14] ARC: locks: remove redundant arch_*_relax operations, Will Deacon
- [PATCH v6 0/5] qrwlock: Introducing a queue read/write lock implementation,
Waiman Long
- [PATCH 00/11] Consolidate asm/fixmap.h files,
Mark Salter
- Re: [tip:x86/asm] x86, bitops: Change bitops to be native operand size,
Joe Perches
- Re: [PATCH v5 4/4] qrwlock: Use the mcs_spinlock helper functions for MCS queuing,
Paul E. McKenney
- Re: [PATCH v5 1/4] qrwlock: A queue read/write lock implementation,
Paul E. McKenney
- [PATCH v5 2/4] MCS Lock: optimizations and extra comments,
Tim Chen
- [PATCH v5 4/4] MCS Lock: Barrier corrections,
Tim Chen
- Re: [PATCH v5 4/4] MCS Lock: Barrier corrections, Paul E. McKenney
- <Possible follow-ups>
- Re: [PATCH v5 4/4] MCS Lock: Barrier corrections, George Spelvin
[PATCH v5 3/4] MCS Lock: Move mcs_lock/unlock function into its own file,
Tim Chen
[PATCH v5 1/4] MCS Lock: Restructure the MCS lock defines and locking code into its own file,
Tim Chen
[PATCH v5 0/4] MCS Lock: MCS lock code cleanup and optimizations, Tim Chen
[PATCH v4.1 5/5] MCS Lock: Use arch-specific load-acquire/store-release primitives, Waiman Long
Re: [PATCH 2/4] arch: Clean up asm/barrier.h implementations using asm-generic/barrier.h,
Mathieu Desnoyers
Fwd: (forw) [mathieu.desnoyers@xxxxxxxxxxxx: Re: [PATCH 1/4] doc: Rename LOCK/UNLOCK to ACQUIRE/RELEASE], Mathieu Desnoyers
Re: [PATCH 3/4] arch: Introduce smp_load_acquire(), smp_store_release(),
Paul Mackerras
Re: [PATCH 4/4] perf: Optimize perf_output_begin() -- weaker memory barrier,
Mathieu Desnoyers
[Index of Archives]
[Kernel Announce]
[Kernel Newbies]
[Linux RAID]
[IETF Annouce]
[Security]
[Netdev]
[Linux Wireless]
[Netfilter]
[Bugtraq]