On 09/23/15 at 10:49am, Baoquan He wrote: > On 09/23/15 at 09:37am, Dave Young wrote: > > > > Hi, Dave. > > > > > > > > How about removing all of the prefix "crashkernel" in kexec_core. Thus > > > > we can be consistent with the output message prefix "kexec". > > > > > > Ping, any comment is appreciate and helpful. > > > > Remove "crashkernel" sounds not a proper way, it indicates crashkernel parsing > > messages. I have no idea what is the best way but below modification sounds better to me: > > > > kexec_core.c: > > > > #define pr_fmt(fmt) "[kexec_core] " fmt > > Also remove below prefix "Kexec:" > > pr_warn("Kexec: Memory allocation for saving cpu register states failed\n"); > > > > kexec.c: > > #define pr_fmt(fmt) "[kexec] " fmt > > > > kexec_file.c: > > #define pr_fmt(fmt) "[kexec_file] " fmt > > This is weird, user really don't need to know each file. I saw you added > a new file kexec_internal.h and all three files includes it. Why not doing > it there to make it the same as before? I personally do not like add these prefix to a header file. One prefix for a c file is better to me. But rethinking about the prefix, looks like there's a lot of other components using ":" so KBUILD_MODNAME ": " should be fine. Thanks Dave