Re: Help needed with Grafana password

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


It's the '#' character, everything after (including '#' itself) is cut off. I tried with single and double quotes which also failed. But as I already said, use a simple password and then change it within grafana. That way you also don't have the actual password lying around in clear text in a yaml file...

Zitat von Eugen Block <eblock@xxxxxx>:

I just tried it on a 17.2.6 test cluster, although I don't have a stack trace the complicated password doesn't seem to be applied (don't know why yet). But since it's an "initial" password you can choose something simple like "admin", and during the first login you are asked to change it anyway. And then you can choose your more complicated password, I just verified that.

Zitat von Sake Ceph <ceph@xxxxxxxxxxx>:

I tried everything at this point, even waited a hour, still no luck. Got it 1 time accidentally working, but with a placeholder for a password. Tried with correct password, nothing and trying again with the placeholder didn't work anymore.

So I thought to switch the manager, maybe something is not right (shouldn't happen). But applying the Grafana spec on the other mgr, I get the following error in the log files:

services/grafana/ceph-dashboard.yml.j2 Traceback (most recent call last): File "/usr/share/ceph/mgr/cephadm/", line 40, in render template = self.env.get_template(name) File "/lib/python3.6/site-packages/jinja2/", ine 830, in get_template return self._load_template(name, self.make_globals(globals)) File "/lib/python3.6/site-packages/jinja2/", line 804, in _load_template template = self.loader.load(self, name, globals) File "/lib/python3.6/site-packages/jinja2/", line 113, in load source, filename, uptodate = self.get_source(environment, name) File "/lib/python3.6/site-packages/jinja2/", line 235, in get_source raise TemplateNotFound(template) jinja2.exceptions.TemplateNotFound: services/grafana/ceph-dashboard.yml.j2

During handling of the above exception, another exception occurred: Traceback (most recent call last): File "/usr/share/ceph/mgr/cephadm/", line 1002, in _check_daemons self.mgr._daemon_action(daemon_spec, action=action) File "/usr/share/ceph/mgr/cephadm/", line 2131, in _daemon_action daemon_spec.daemon_type)].prepare_create(daemon_spec) File "/usr/share/ceph/mgr/cephadm/services/", line 27, in prepare_create daemon_spec.final_config, daemon_spec.deps = self.generate_config(daemon_spec) File "/usr/share/ceph/mgr/cephadm/services/", line 54, in generate_config 'services/grafana/ceph-dashboard.yml.j2', {'hosts': prom_services, 'loki_host': loki_host}) File "/usr/share/ceph/mgr/cephadm/", line 109, in render return self.engine.render(name, ctx) File "/usr/share/ceph/mgr/cephadm/", line 47, in render raise TemplateNotFoundError(e.message) cephadm.template.TemplateNotFoundError: services/grafana/ceph-dashboard.yml.j2

I use the following config for Grafana, nothing special.

service_type: grafana
service_name: grafana
 count: 2
 label: grafana
- -v=/opt/ceph_cert/host.cert:/etc/grafana/certs/cert_file:ro
- -v=/opt/ceph_cert/host.key:/etc/grafana/certs/cert_key:ro
 anonymous_access: true
 initial_admin_password: aPassw0rdWithSpecialChars-#

ceph-users mailing list -- ceph-users@xxxxxxx
To unsubscribe send an email to ceph-users-leave@xxxxxxx

[Index of Archives]     [Information on CEPH]     [Linux Filesystem Development]     [Ceph Development]     [Ceph Large]     [Ceph Dev]     [Linux USB Development]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [xfs]

  Powered by Linux