Re: Re : Radeon 9000 : working but !!!!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Wed, 2002-11-27 at 12:07, Rich wrote:

Hi Rich,

I've got RH 8 box running an ATi 9000 PRO as well. My card is made by
Saphire and is so classed as a Powered By ATi card, rather than a Built
By ATi which is what ATi classes as the card they've made themselves.
They do support MDK 9 with these drivers so it is probably the best bet
for you.

Here is how I installed them on RH 8. As root:

1. init 3 in GNOME, drop me to a console (no X for safety).
2. "rpm -i --force <ati_drivers.rpm>"
3. "fglrxconfig" to set-up /etc/X11/X86Config

Now this caused one problem initially. The fglrxconfig adds this line to
the XF86Config:

    BusID "PCI:1:0:0"    # vendor=1002, device=496e

For me, the BusID was PCI:1:0:1 - can be found via lspci. If it is the
wrong one, you'll get "no screens found" and it won't get very far.
Also, you can just comment this line out as XFree86 will generally find
a graphics card itself if there is just one in the system.

Then I ran into this problem using ATi's fglrx driver module:

(--) fglrx(0): Chipset: "Radeon RV250 If" (Chipset = 0x4966)
(--) fglrx(0): (PciSubVendor = 0x148c, PciSubDevice = 0x2039)
(--) fglrx(0): board vendor info: third party grafics adapter - NOT
original ATI
(--) fglrx(0): Linear framebuffer (phys) at 0xd8000000
(--) fglrx(0): MMIO registers at 0xe9000000
(--) fglrx(0): ChipRevID = 0x00
(--) fglrx(0): VideoRAM: 131072 kByte (64-bit DDR SDRAM)
(EE) fglrx(0): board/chipset is not supported by this driver (third
party board)
(EE) fglrx(0): PreInitConfig failed

Because my card is a Powered By ATi card, it doesn't work. I then got
"hexedit" from and used it to alter this file:


To get it work hexedit offset 0x626e: 74 44 --> 90 90

Start X and it works just fine. Note I didn't find the above, but it
does work. Even OpenGL flies along now!!

If you need extra info, ask further!



> Hi,
> I posted some stuff a few days ago asking about getting a mobile 9000 working 
> on FreeBSD. I have tried all the things that have been suggested (plus some), 
> but to no avail.
> Since then, I have replaced FreeBSD with Mandrake 9.0 (I didn't want to do 
> this to be honest - I really wanted to use BSD, but I simply can't affort the 
> time to get X working on it, and I really NEED X). Anyway, what I'm getting 
> to is.....
> I have now managed to get my 9000 working in VESA mode. It doesn't run too 
> bad, but if you can tell me what you did to get your 9000 working (in '9000' 
> mode), then I would be really greatful. I tried selecting 'radeon' in the 
> Drakxconfig when I installed Mandrake, but when I tested it from within the 
> config tool, it told me it couldn't find the hardware. I also tried selecting 
> the ATI driver too, but no good.
> After installation, I played about with the X config manually to try and 
> improve things, but again, no good - it can't find the hardware. It's 
> definitely bringing in the radeon driver (and the ATI one), I've tried 
> forcing a ChipId of 0x4242 (which I believe is the 8500) and 0x4c66 (which is 
> what scanpci returns for my 9000), but it didn;t work. By the way, can 
> someone tell me what the correct syntax for 'ChipId' is ?...
> ChipID 0x4242 .... doesn't work - syntax error reported in config file
> Option "ChipID" "0x4242" ... no syntax error but doesn't seem to do anything 
> X has also reported on occasion (on startup) that "You have a valid 
> configuration, but it's not listed in the *" (* = sorry - can't remember the 
> name of the file !!! ...PciConfig or something like that). Anyway, I have 
> tried in the past (with BSD) to add the 0x4c66 chip id to this and it didn't 
> work (mostly because I couldn't select the radeon driver, but that's another 
> story - see previous posts - "Where is the the radeon 9000 ???"
> Anyway, sorry to go on...
> If you could post up your Xfree config or something, that would be great !! 
> Or any info at all !!!
> Rich.
> _______________________________________________
> Newbie@XFree86.Org
> *** To unsubscribe , or change message options, see:
> http://XFree86.Org/mailman/listinfo/newbie


*** To unsubscribe , or change message options, see:

[Index of Archives]     [XFree86]     [Xfree86 Xpert]     []     [IETF Annouce]     [Security]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Picture Sharing]     [Linux Security]     [Linux RAID]

  Powered by Linux