Re: Re : Radeon 9000 : working but !!!!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi yall & Rich,

yep, you have been putting in some serious efforts.

I am guessing, you do not know that ATI have released drivers for the 9000 series?

Mandrake 9.0, "should" be an easy install.


Greek Geek :-)

I know you think you have won, Mr Gates. So did the Trojan's & my ancestors dealt with them
& we shall deal with you. --GG, on Debian Linux.

Rich wrote:


I posted some stuff a few days ago asking about getting a mobile 9000 working on FreeBSD. I have tried all the things that have been suggested (plus some), but to no avail.

Since then, I have replaced FreeBSD with Mandrake 9.0 (I didn't want to do this to be honest - I really wanted to use BSD, but I simply can't affort the time to get X working on it, and I really NEED X). Anyway, what I'm getting to is.....

I have now managed to get my 9000 working in VESA mode. It doesn't run too bad, but if you can tell me what you did to get your 9000 working (in '9000' mode), then I would be really greatful. I tried selecting 'radeon' in the Drakxconfig when I installed Mandrake, but when I tested it from within the config tool, it told me it couldn't find the hardware. I also tried selecting the ATI driver too, but no good.

After installation, I played about with the X config manually to try and improve things, but again, no good - it can't find the hardware. It's definitely bringing in the radeon driver (and the ATI one), I've tried forcing a ChipId of 0x4242 (which I believe is the 8500) and 0x4c66 (which is what scanpci returns for my 9000), but it didn;t work. By the way, can someone tell me what the correct syntax for 'ChipId' is ?...

ChipID 0x4242 .... doesn't work - syntax error reported in config file
Option "ChipID" "0x4242" ... no syntax error but doesn't seem to do anything
X has also reported on occasion (on startup) that "You have a valid configuration, but it's not listed in the *" (* = sorry - can't remember the name of the file !!! ...PciConfig or something like that). Anyway, I have tried in the past (with BSD) to add the 0x4c66 chip id to this and it didn't work (mostly because I couldn't select the radeon driver, but that's another story - see previous posts - "Where is the the radeon 9000 ???"

Anyway, sorry to go on...

If you could post up your Xfree config or something, that would be great !! Or any info at all !!!


*** To unsubscribe , or change message options, see:


*** To unsubscribe , or change message options, see:

[Index of Archives]     [XFree86]     [Xfree86 Xpert]     []     [IETF Annouce]     [Security]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Picture Sharing]     [Linux Security]     [Linux RAID]

  Powered by Linux