bug in trn -c

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I think I've found a bug in trn 4.0-test76.  When I run "trn -c", and
the .newsrc file contains a line of length exactly 28 characters, then
some memory allocation problem causes .newsrc to be replaced with a
file that contains garbage text.  For example, if my .newsrc contains
the following lines (the first has length 28):

comp.ai.neural-nets: 1-53695
sci.agriculture.fruit: 1-3354
rec.puzzles: 1-155831

and I run "trn -c", then .newsrc is replaced with the lines:


A workaround I've found is to take out the following portion of
rcstuff.c (beginning on line 530:

	if (checkflag)			/* no extra mallocs for -c */
	    np->rcline = some_buf;

Here is the configuration of the trn that I'm using:

Trn version: 4.0-test76 (Apr 2, 2001).
Configured for NNTP (plus individual local access).

News source group #1:

ID default:
Newsrc /u/jweening/.newsrc.
News from server lydian.ccrwest.org.
Dynamic active file.
Copy of remote group desc. file (refetch: 4 hours).
Overview files from /tmp.

This sf.net email is sponsored by:ThinkGeek
Welcome to geek heaven.

[Index of Archives]     [Photo]     [Yosemite]     [Epson Inkjet]     [Mhonarc]     [Nntpcache]

  Powered by Linux