[Sound] Re: It's not just an ESS1869 problem..... (Solved!)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<


I pulled a SoundBlaster Live out of another computer and put it in my RH9
system that had just been freshly installed.

Amazingly, the SB Live has exactly the same problem that the old ESS1869 ISA
bus card has! Since thousands and thousands of people have installed SB
Live's under Linux, this must be a problem with my system. It's rather old
(AMD K6 at 300 MHz on an AT Socket 7 motherboard), but that's the only
peculiar thing I can think of.

I have not the slightest idea how to resolve this problem.



I got lucky and found the problem. In the Gnome desktop, under "preferences"
and "sound" there is an option called "Enable sound system startup". It is
not selected by default during installation but sure ought to be if a
soundcard is detected!

Thanks to Bill for all the help. No thanks to Gnome for making this harder
than it needed to be by defaulting to "off". It would be helpful if the
Linux documentation informed users that the modules.conf setting can be
automatically overridden.



OK on the alias functionality.

Here's a real description of my system and what it is/is not doing :

Modules.conf :

	alias sound-slot-0 = sb
	post-install sound-slot-0 /bin/aumix etc.
	pre-remove sound-slot-0 /bin/aumix etc

After boot-up lsmod does not show sb as being loaded.

I then start CDPlayer and it thinks all is well and plays the CD, but no
audio is outputted from the ESS1869 sound card.

At this point, a new lsmod shows that sb is still not loaded.

If I then do a modprobe sb, the sound appears immediately.

Another lsmod shows me that 4 new modules are now present: sb, sb_lib,
uart401, sound, and soundcore.

What can I do?

Thanks for the help so far.


[Index of Archives]     [Sound Cards]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp Users]     [Yosemite Trails]

  Powered by Linux