Re: pulseaudio parec recording short interrupt at user switch

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Sun, Sep 05, 2021 at 10:37:16PM +0200, Istvan Gabor wrote:
> Sat, 4 Sep 2021 20:36:35 -0700 időpontban Sean Greenslade írta:
> > Are these actually different system (unix) users? With different UIDs?
> > If so, pulse doesn't really work in a multi-user environment by default.
> > How have you configured pulse to use multiple users? That may shed some
> > light on what's causing your cut-outs.
> Thank you.
> These are two different users with different UIDs.
> They work alternately in the system. User2 records the stream in his session
> in VT8 X11 terminal. After starting to record user1 switches to his VT7
> X11 session. Occasionally user2 switches bacj to his session. During the
> record they switch sessions several times.
> I haven't configured pulseaudio, just use the default openSUSE setup.
> Earlier I tried system-wide pulseaudio to be able to listen to the stream
> in both sessions. It worked, but pacmd doesn't work in system wide mode,
> therefore I removed it (the pulseaudio system wide package).

I suppose this setup should work in theory, assuming you're only feeding
streams to a null sink and not to actual hardware ALSA devices.

Can you check the logs to see if pulse is doing anything odd during the
VT switches? I'm assuming openSUSE is systemd-based, so pulse is
probably launched / killed by user units. See what's returned by these
commands after reproducing your issue:

$ journalctl --user -u pulseaudio.service -b

$ journalctl --user -u pulseaudio.socket -b


[Index of Archives]     [Linux Audio Users]     [AMD Graphics]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux