Re: No audio output; same setup worked before

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Sat, Feb 13, 2021 at 01:25:22PM -0800, Rich Shepard wrote:
> On Sat, 13 Feb 2021, Sean Greenslade wrote:
> > Are you referring to the Kodi project's PAPlayer, or did you use "paplay"?
> > What happens if you try paplay? What are the error messages you get, if
> > any?
> No, 'paplay':
> $ paplay test-recording.flac Failed to open audio file.
> But,
> $ pacat -p test-recording.flac
> no sound.
> > Also, can you open the generated .flac file with an audio editor to see
> > if the audio actually got recorded in the first place?
> Ah, nope. Audacity can't find content and 'ffprobe' returns,
> $ ffprobe -hide_banner test-recording.flac [flac @ 0xc60d60] Format flac
> detected only with low score of 1, misdetection possible!
> [flac @ 0xc60d60] Could not find codec parameters for stream 0 (Audio: flac, 0 channels): unspecified sample format
> Consider increasing the value for the 'analyzeduration' and 'probesize' options
> Input #0, flac, from 'test-recording.flac':
>   Duration: N/A, bitrate: N/A
>     Stream #0:0: Audio: flac, 0 channels

OK, all of this suggests that the file did not record correctly. And
after some experimentation myself, it seems like this is a known bug:

It seems like the wav format does work, so give this variant a try:

$ pacat -v -r --file-format=wav /tmp/sounds.wav


$ pacat -v -p --file-format=wav /tmp/sounds.wav

> On a different file (created yesterday):
> $ ffprobe -hide_banner test-mic.wav Input #0, wav, from 'test-mic.wav':
>   Duration: 00:00:16.00, bitrate: 64 kb/s
>     Stream #0:0: Audio: pcm_u8 ([1][0][0][0] / 0x0001), 8000 Hz, 1 channels, u8, 64 kb/
> and
> $ pacat -p test-mic.wav
> produced two clicks from the speaker.
> Found one potential issue: the Focusrite had the 'Air' button pressed under
> the input volumn knob. Turned that off. Now when I speak into the mic the
> green ring light around the volumn knob fluctuates as does the pavucontrol
> VU meter. But, still no output from the speakers.

My Scarlett solo is an older gen, so it doesn't have an "air" switch. I
was curious what that was, so here's what their docs have to say:

>> An important feature of all 3rd Generation Scarlett interfaces is
>> Focusrite’s exclusive AIR function.  Individually selectable on all
>> mic input channels, AIR subtly modifies the preamp’s frequency
>> response to model the sonic characteristics of our classic
>> transformer-based ISA microphone preamps. When recording with good
>> quality microphones, you will notice an enhanced clarity and
>> definition in the important mid to high frequency range, just where it
>> is most needed for vocals and many acoustic instruments.

Lol, it's just a fixed EQ curve. This should not be the cause of your
issues, though feel free to use it if you like the tone it produces.


pulseaudio-discuss mailing list

[Index of Archives]     [Linux Audio Users]     [AMD Graphics]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux