On Wed, Oct 20, 2010 at 12:54:20PM -0400, Joe Perches wrote: > On Wed, 2010-10-20 at 09:49 -0700, Guenter Roeck wrote: > > On Wed, Oct 20, 2010 at 11:59:23AM -0400, > > Joe Perches wrote: > > [ ... ] > > > Anyway, I'd like to sort it out eventually. > > > For now, I just add the #define pr_fmt, with > > > a long term goal of removing them all and using > > > a different mechanism to remove the duplicated > > > prefix string altogether from the formats and > > > save some text. > > I don't mind individual pr_fmt defines as long as they are used. > > However, that is not the case in many of the patches. > > Just adding a pr_fmt define to a file without using it doesn't make sense to me. > > kernel.h has the equivalent of: > > #define pr_<level>(fmt, arg...) printk(KERN_<level> pr_fmt(fmt), ##arg) > And no one minds that there are literally hundreds of equivalent defines for pr_fmt in the code, and even more conflicting ones ? Odd. Maybe the following in kernel.h would make more sense. #ifndef pr_fmt #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt #endif At least it would make more sense than littering source files with pr_fmt definitions. If that doesn't fly, I would prefer to stick with the existing default definition in kernel.h. At least that would give people an incentive to fix the problem in kernel.h (or in some other central location) if they dislike the resulting missing module names. Thanks, Guenter _______________________________________________ lm-sensors mailing list lm-sensors@xxxxxxxxxxxxxx http://lists.lm-sensors.org/mailman/listinfo/lm-sensors