On 08/24/2011 05:25 PM, Vasanthakumar Thiagarajan wrote: > +#ifdef CONFIG_ATH6KL_DEBUGFS > +int ath6kl_init_debugfs(struct ath6kl *ar); > +#else > +static inline int ath6kl_init_debugfs(struct ath6kl *ar) > +{ > + return 0; > +} > +#endif I would prefer to call this ath6kl_debug_init(). That way we can put all debug initialisation into that, not just debugfs code. And then the ifdef should check for CONFIG_ATH6KL_DEBUG. Kalle -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html