On Wed, Aug 24, 2011 at 05:39:48PM +0300, Kalle Valo wrote: > On 08/24/2011 05:25 PM, Vasanthakumar Thiagarajan wrote: > > +#ifdef CONFIG_ATH6KL_DEBUGFS > > +int ath6kl_init_debugfs(struct ath6kl *ar); > > +#else > > +static inline int ath6kl_init_debugfs(struct ath6kl *ar) > > +{ > > + return 0; > > +} > > +#endif > > I would prefer to call this ath6kl_debug_init(). That way we can put all > debug initialisation into that, not just debugfs code. And then the > ifdef should check for CONFIG_ATH6KL_DEBUG. May be, but I think we can't always enable debugfs based on only CONFIG_ATH6KL_DEBUG as the general debug does not depend on CONFIG_DEBUG_FS. Vasanth -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html