On 08/14/2013 07:51 PM, Sergei Shtylyov wrote: > Hello. Hi Sergei, > [...] >> +USB >> +~~~ >> +compatible: ti,musb-am33xx >> +reg: offset and length "USB Controller Registers" >> +reg-names: control >> + >> +This node contains the musb core: >> +- compatible: "mg,musbmhdr" > > "mg,musbmhdrc" you mean? Yes. >> +- multipoint : Should be "1" indicating the musb controller supports >> multipoint. This is a MUSB configuration-specific setting. > [...] >> +- num-eps : Specifies the number of endpoints. This is also a >> + MUSB configuration-specific setting. Should be set to "16" >> +- ram-bits : Specifies the ram address size. Should be set to "12" >> +- port-mode : Should be "3" to represent OTG. "1" signifies HOST and "2" >> + represents PERIPHERAL. > > The above props should probably be prefixed with "mg," being Mentor > Graphics specific. This wasn't done in the other dts files but this does not make it right. I fix it up. >> +- power : Should be "250". This signifies the controller can supply >> up to >> + 500mA when operating in host mode. > > This one too. Hmm. I'm not too happy with this beeing as defined by the USB specification. Would you mind if I change it to mA instead? >> +- phys: reference to the USB phy >> +- dmas: specifies the dma channels >> +- dma-names: specifies the names of the channels. Use "rxN" for receive >> + and "txN" for transmit endpoints. N specifies the endpoint number. >> + >> +The controller should have an "usb" alias numbered properly in the alias >> +node. >> + >> +DMA >> +~~~ >> +- compatible: ti,am3359-cppi41 > > "ti,cppi41" should follow I think. I would go for ti,am3359-cppi41 because it has been tested on this device. I wouldn't mind flipping 9 by an x. The problem is that it is not generic cppi41 because it needs that glue thingy and it is only able to do USB transfers. So adding a trailing USB might be good but the am335x has only one cppi41 engine which does USB (the network one is cppi3 something). What you think? >> +- reg: offset and length of the following register spaces: USBSS, USB >> + CPPI DMA Controller, USB CPPI DMA Scheduler, USB Queue Manager >> +- reg-names: glue, controller, scheduler, queuemgr >> +- #dma-cells: should be set to 2. The first number represents the >> + endpoint number (0 … 14 for endpoints 1 … 15 on instance 0 and 15 … 29 >> + for endpoints 1 … 15 on instance 1). The second number is 0 for RX and >> + 1 for TX transfers. >> +- #dma-channels: should be set to 30 representing the 15 endpoints for >> + each USB instance. >> + usb0_phy: phy@47401300 { > > Perhaps better name it "usb-phy", the same as there's "ethernet-phy" > in ePAPR spec... Okay, that would be usb0-phy then. >> + compatible = "ti,am335x-usb-phy"; >> + reg = <0x47401300 0x100>; >> + reg-names = "phy"; >> + ti,ctrl_mod = <&ctrl_mod>; >> + }; >> + cppi41dma: dma@07402000 { > > Should be named "dma-controller", not just "dma" according to the > ePAPR spec: Yup, okay, will do. Thanks Sergei. > > http://www.power.org/resources/downloads/Power_ePAPR_APPROVED_v1.0.pdf > > WBR, Sergei > Sebastian -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html