Re: [PATCH 1/2] usb: usb: dsps: update device tree bindings

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hello.

On 08/14/2013 09:29 PM, Sebastian Andrzej Siewior wrote:

The support for both am335x-USB instances required changes to the device
tree bindings. This patch reflects these changes in the bindings
document.

Signed-off-by: Sebastian Andrzej Siewior <bigeasy@xxxxxxxxxxxxx>
---
  .../devicetree/bindings/usb/am33xx-usb.txt         | 239 ++++++++++++++++++---
  1 file changed, 210 insertions(+), 29 deletions(-)

diff --git a/Documentation/devicetree/bindings/usb/am33xx-usb.txt b/Documentation/devicetree/bindings/usb/am33xx-usb.txt
index dc9dc8c..4afb92b 100644
--- a/Documentation/devicetree/bindings/usb/am33xx-usb.txt
+++ b/Documentation/devicetree/bindings/usb/am33xx-usb.txt
@@ -1,35 +1,216 @@
[...]
+USB
+~~~
+compatible: ti,musb-am33xx
+reg: offset and length "USB Controller Registers"
+reg-names: control
+
+This node contains the musb core:
+- compatible: "mg,musbmhdr"

   "mg,musbmhdrc" you mean?

+- multipoint : Should be "1" indicating the musb controller supports
     multipoint. This is a MUSB configuration-specific setting.
[...]
+- num-eps : Specifies the number of endpoints. This is also a
+  MUSB configuration-specific setting. Should be set to "16"
+- ram-bits : Specifies the ram address size. Should be set to "12"
+- port-mode : Should be "3" to represent OTG. "1" signifies HOST and "2"
+  represents PERIPHERAL.

The above props should probably be prefixed with "mg," being Mentor Graphics specific.

+- power : Should be "250". This signifies the controller can supply up to
+  500mA when operating in host mode.

   This one too.

+- phys: reference to the USB phy
+- dmas: specifies the dma channels
+- dma-names: specifies the names of the channels. Use "rxN" for receive
+  and "txN" for transmit endpoints. N specifies the endpoint number.
+
+The controller should have an "usb" alias numbered properly in the alias
+node.
+
+DMA
+~~~
+- compatible: ti,am3359-cppi41

   "ti,cppi41" should follow I think.

+- reg: offset and length of the following register spaces: USBSS, USB
+  CPPI DMA Controller, USB CPPI DMA Scheduler, USB Queue Manager
+- reg-names: glue, controller, scheduler, queuemgr
+- #dma-cells: should be set to 2. The first number represents the
+  endpoint number (0 … 14 for endpoints 1 … 15 on instance 0 and 15 … 29
+  for endpoints 1 … 15 on instance 1). The second number is 0 for RX and
+  1 for TX transfers.
+- #dma-channels: should be set to 30 representing the 15 endpoints for
+  each USB instance.
+	usb0_phy: phy@47401300 {

Perhaps better name it "usb-phy", the same as there's "ethernet-phy" in ePAPR spec...

+		compatible = "ti,am335x-usb-phy";
+		reg = <0x47401300 0x100>;
+		reg-names = "phy";
+		ti,ctrl_mod = <&ctrl_mod>;
+	};
+	cppi41dma: dma@07402000 {

   Should be named "dma-controller", not just "dma" according to the ePAPR spec:

http://www.power.org/resources/downloads/Power_ePAPR_APPROVED_v1.0.pdf

WBR, Sergei

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux