Re: [PATCH 08/20] usb: host: xhci: give xhci a platform_device

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Aug 15, 2011 at 04:51:29PM +0200, Sebastian Andrzej Siewior wrote:
> From: Felipe Balbi <balbi@xxxxxx>
> 
> it will make it simpler to re-use the stack
> if it's not tied to a particular bus. Later
> patches should come to phase PCI bus to a
> separate piece of code which doesn't touch
> xhci.c.

This patch looks fine, only one small nitpick here:

> +err5:
> +	usb_put_hcd(xhci->shared_hcd);
> +
> +err4:
> +	usb_remove_hcd(hcd);
> +
> +err3:
> +	iounmap(hcd->regs);
> +
> +err2:
> +	release_mem_region(hcd->rsrc_start, hcd->rsrc_len);
> +
> +err1:
> +	usb_put_hcd(hcd);
> +
> +err0:
> +	return ret;
> +}

Can you please rename these labels to have descriptive names like
put_hcd?  It's a pet peeve of mine because it can often hide issues when
you add code later and make a mistake about which error code you wanted
to jump to.

Sarah Sharp
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux