Hi Ricardo,
Ricardo Ribalda Delgado 於 2016/9/1 下午 07:16 寫道:
+static void fintek_8250_set_max_fifo(struct fintek_8250 *pdata)
+{
+ switch (pdata->pid) {
+ default: /* Default 16Bytes FIFO */
+ return;
+
+ case CHIP_ID_F81216H: /* 128Bytes FIFO */
+ sio_write_mask_reg(pdata, FIFO_CTRL,
+ FIFO_MODE_MASK | RXFTHR_MODE_MASK,
+ FIFO_MODE_128 | RXFTHR_MODE_4X);
+ break;
+ }
I think it is more clear to have the default case as the ast one;
OK, I'll modify all default label to the last one.
+}
+
static int find_base_port(struct fintek_8250 *pdata, u16 io_address,
unsigned int irq)
I think that we should rename find_base_port to something else like
probe_setup_port(), we are not only finding the port but also setting
it up.
OK, I'll modify it with next version.
--
With Best Regards,
Peter Hong
--
To unsubscribe from this list: send the line "unsubscribe linux-serial" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html