Re: printing

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



I want to share firstly a brief history of my problem that lasts at
least  three years in different ways in different versions of dosemu.

First of all I used older version that i used in RedHat 8.0.
Everything worked well.
After that I upgraded dosemu and I used lpd printing and that
"upgraded" version of dosemu with the same DOS application and the
same printer did not print well but in /var/spool/lpd sent file that
was actually ASCII and I imported it in my Openoffice and ptinted it
out. Clumys, but it worked.
At the time I have had on this mailing list discussion with person
called Claudia or so.
When I installed Vector Linux KDE Classic v 6.0 ( and
installed dosemu package compatible with Vector Linux and Slackware
12.1 (Vector Linux is Slackware based distro)  my DOS application is
workin well , using CUPS and it does not print nor it creates in
/var/spool/cups anything that can be used to do workaround.
Even more strange is that CUPS reports that print job is accepted and
successfuly done.
Indeed, I print normally using that printer from OpenOffice etc.
If you need more technical information on HP1020 and its driver please
check this site:

Please note what developer of driver says for the printer:
These printers are often erroneously referred to as winprinters or GDI
printers. However, Microsoft GDI only mandates the API between an
application and the printer driver, not the protocol on the wire
between the printer driver and the printer. In fact, ZjStream printers
are raster printers which happen to use a very efficient wire protocol
which was developed by Zenographics and licensed by most major printer
manufacturers for at least some of their product lines. ZjStream is
just one of many wire protocols that are in use today, such as
Postscript, PCL, Epson, etc.

Please pay attention to the components of driver and their
functionality  on the same page.



On Fri, Nov 26, 2010 at 2:15 AM, Andrew Joakimsen <joakimsen@xxxxxxxxx> wrote:
> On Tuesday, November 23, 2010, Vedran Vucic <vedran.vucic@xxxxxxxxx> wrote:
>> Hello,
>> When I clean /var/spool/cups and do print from my DOS app to printer I
>> get the queue file like one I sent already but it does not come out to
>> the printer.
>> When I get to/var/log/cups/access_log
>> then I see that last message is that Print Job is successful-ok.
>> But,nothing comes out of the printer nor printer blinks as a reaction
>> to receiving data.
>> When I Go to http://localhost:631 and print test page everything isOK
>> whichmeans that printer and connection with printer is OK.
>> Strange, isn't it?
>> If you want I can again put my dosemu.conf on pastebin.
>> Thanks,
>> Vedran
>> On Tue, Nov 23, 2010 at 8:58 PM, Mike McCarty
>> <Mike.McCarty@xxxxxxxxxxxxx> wrote:
>>> Vedran Vucic wrote:
>>>> Hello,
>>> [...]
>>>> When I use option in my DOS application to print on screen it creates .prn
>>>> file.
>>>> is it possible to print that .prn file from dosemu?
>>> Hmm. MSDOS uses PRN as a special device. I wonder if your program
>>> is trying to use that, and it's not getting to the printer. You
>>> know, like CON:
>>> BTW, did you check the queue to see if it's stalled?
>>> Mike
>>> --
>>> p="p=%c%s%c;main(){printf(p,34,p,34);}";main(){printf(p,34,p,34);}
>>> Oppose globalization and One World Governments like the UN.
>>> This message made from 100% recycled bits.
>>> You have found the bank of Larn.
>>> I speak only for myself, and I am unanimous in that!
>>> --
>>> To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
>>> the body of a message to majordomo@xxxxxxxxxxxxxxx
>>> More majordomo info at Â
>> --
>> To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
>> the body of a message to majordomo@xxxxxxxxxxxxxxx
>> More majordomo info at Â
> Which, again, goes back to what i said originally:
> Your DOS program expects to be running on a real computer, attached to
> a real printer. You have what I belive to be a winprinter meaning it
> does not work with PCL5 or PostScript languages. Therefore configure
> your DOS program to print to a PostScript driver and CUPS should
> handle the translation.
> If my assumptions about your printer are correct, setting your printer
> to use HP LaserJet III driver in CUPS will not work, and I never saw a
> PostScript printer that didnt support PCL5.
> --
> Med Vennlig Hilsen,
> A. Helge Joakimsen
To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux