dosemu error -- LOWRAM mmap: Invalid argument

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


When I run dosemu I get these error messages:

  LOWRAM mmap: Invalid argument
  Segmentation fault

I have already done this as root -- recommended as the 
solution for this problem -- but it doesn't help:

  echo 0 > /proc/sys/vm/mmap_min_addr

and "cat /proc/sys/vm/mmap_min_addr" now prints 0
(I think it was originally something like 65536).

The dosemu version is, installed from an OpenSuse rpm.

I'm running OpenSuse Linux 11.2, kernel,
which is a 32-bit system.

I get those error messages whether I run dosemu in an xterm
or a Linux text console.

My CPU is an AMD Athlon XP 2800+ dual-core 64 bit.

This is my first time running dosemu.

Here's my boot.log:

CONF: config variable parser_version_3 set
CONF: config variable c_system set
CONF: Parsing built-in dosemu.conf file.
CONF: config variable version_3_style_used set
CONF: Parsing built-in global.conf file.
CONF: config variable version_3_style_used unset
CONF: config variable version_3_style_used set
CONF: opened include file /etc/dosemu/dosemu.conf
CONF: closed include file /etc/dosemu/dosemu.conf
CONF: opened include file /home/msb/.dosemurc
CONF: closed include file /home/msb/.dosemurc
CONF: config variable skip_dosrc set
CONF: mapping driver = 'auto'
debug flags: -a+cw
CONF: Disabling use of pentium timer
CONF: dosbanner on
CONF: timer freq=18, update=54925
CONF: CPU set to 586
CONF: JIT CPUEMU set to 0 for 586
CONF: 2048k bytes EMS memory
CONF: EMS-frame = 0xe400
CONF: DPMI-Server on (0x5000)
CONF: DPMI base addr = 0xffffffff
CONF: PM DOS API Translator on
CONF: No DJGPP NULL deref checks: off
CONF: dosemu running on X
CONF: x keycode 2 mode13fact 2 gamma 100 font '' mgrab_key "Home"
CONF: time mode = 'bios'
SER: directory /var/lock namestub LCK.. binary No
MOUSE: no device specified, type 0 using internaldriver: yes, emulate3buttons: no baudrate: 0
CONF: Keyboard-layout keyb-user
CONF: **** Warning: floppy /dev/fd0 not accessable, disabled
CONF: fastfloppy = 1
CONF: IPX support off
CONF(LPT0) f: (null)   c: lpr -l  t: 20  port: 0
CONF(LPT1) f: (null)   c: lpr -l -P lpt2  t: 20  port: 0
CONF: not allowing speaker port access
CONF: Packet Driver enabled.
device: /home/msb/.dosemu/drives/c type 4 h: -1  s: -1   t: -1 drive C:
device: /home/msb/.dosemu/drives/d type 4 h: -1  s: -1   t: -1 drive D:
CONF: cdrom MSCD0001 on /dev/cdrom
CONF: config variable c_system unset
Linux kernel 2.6.31; CPU speed is 2712433000 Hz
CPU-EMU speed is 2712 MHz
CONF: mostly running as USER: uid=1000 (cached 1000) gid=100 (cached 100)
DBG_FD already set
DOSEMU- is coming up on Linux version #1 SMP PREEMPT 2010-01-27 08:20:11 +0100 i686
Compiled with GCC version 4.4.0 -m32
CONF: reserving 640Kb at 0x00000 for 'd' (Base DOS memory (first 640K))
CONF: reserving 48Kb at 0xF4000 for 'r' (Dosemu reserved area)
CONF: reserving 128Kb at 0xA0000 for 'v' (Video memory)
CONF: reserving 8256Kb at 0x100000 for 'x' (Extended memory (HMA+XMS))


To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux