Linux Kernel Memory Management
[Prev Page][Next Page]
- [PATCH 15/29] NFSD: dynamically allocate the nfsd-client shrinker, (continued)
- [PATCH 15/29] NFSD: dynamically allocate the nfsd-client shrinker, Qi Zheng
- [PATCH 16/29] NFSD: dynamically allocate the nfsd-reply shrinker, Qi Zheng
- [PATCH 17/29] xfs: dynamically allocate the xfs-buf shrinker, Qi Zheng
- [PATCH 18/29] xfs: dynamically allocate the xfs-inodegc shrinker, Qi Zheng
- [PATCH 19/29] xfs: dynamically allocate the xfs-qm shrinker, Qi Zheng
- [PATCH 20/29] zsmalloc: dynamically allocate the mm-zspool shrinker, Qi Zheng
- [PATCH 22/29] drm/ttm: introduce pool_shrink_rwsem, Qi Zheng
- [PATCH 21/29] fs: super: dynamically allocate the s_shrink, Qi Zheng
- [PATCH 23/29] mm: shrinker: add refcount and completion_wait fields, Qi Zheng
- [PATCH 24/29] mm: vmscan: make global slab shrink lockless, Qi Zheng
- [PATCH 25/29] mm: vmscan: make memcg slab shrink lockless, Qi Zheng
- [PATCH 26/29] mm: shrinker: make count and scan in shrinker debugfs lockless, Qi Zheng
- [PATCH 27/29] mm: vmscan: hold write lock to reparent shrinker nr_deferred, Qi Zheng
- [PATCH 29/29] mm: shrinker: move shrinker-related code into a separate file, Qi Zheng
- [PATCH 28/29] mm: shrinkers: convert shrinker_rwsem to mutex, Qi Zheng
- Re: [PATCH 00/29] use refcount+RCU method to implement lockless slab shrink, Qi Zheng
- [PATCH v1 0/2] udmabuf: Add back support for mapping hugetlb pages,
Vivek Kasireddy
- [PATCH RESEND] elf: correct note name comment,
Baruch Siach
- [PATCH 1/2] Revert "page cache: fix page_cache_next/prev_miss off by one",
Mike Kravetz
- Re: [PATCH 00/79] fs: new accessors for inode->i_ctime,
Steven Rostedt
- [RFC PATCH v2 0/6] mm: working set reporting,
Yuanchu Xie
- Re: [PATCH 01/79] fs: add ctime accessors infrastructure,
Tom Talpey
- [PATCH 00/13] Remove pagevecs,
Matthew Wilcox (Oracle)
- [PATCH 05/13] drm: Convert drm_gem_put_pages() to use a folio_batch, Matthew Wilcox (Oracle)
- [PATCH 06/13] mm: Remove check_move_unevictable_pages(), Matthew Wilcox (Oracle)
- [PATCH 08/13] i915: Convert i915_gpu_error to use a folio_batch, Matthew Wilcox (Oracle)
- [PATCH 13/13] mm: Remove unnecessary pagevec includes, Matthew Wilcox (Oracle)
- [PATCH 07/13] pagevec: Rename fbatch_count(), Matthew Wilcox (Oracle)
- [PATCH 09/13] net: Convert sunrpc from pagevec to folio_batch, Matthew Wilcox (Oracle)
- [PATCH 10/13] mm: Remove struct pagevec, Matthew Wilcox (Oracle)
- [PATCH 11/13] mm: Rename invalidate_mapping_pagevec to mapping_try_invalidate, Matthew Wilcox (Oracle)
- [PATCH 12/13] mm: Remove references to pagevec, Matthew Wilcox (Oracle)
- [PATCH 02/13] mm: Add __folio_batch_release(), Matthew Wilcox (Oracle)
- [PATCH 03/13] scatterlist: Add sg_set_folio(), Matthew Wilcox (Oracle)
- [PATCH 04/13] i915: Convert shmem_sg_free_table() to use a folio_batch, Matthew Wilcox (Oracle)
- [PATCH 01/13] afs: Convert pagevec to folio_batch in afs_extend_writeback(), Matthew Wilcox (Oracle)
- [PATCH 74/79] shmem: switch to new ctime accessors, Jeff Layton
- [PATCH 39/79] hugetlbfs: switch to new ctime accessors, Jeff Layton
- [PATCH 12/79] fs: switch to new ctime accessors,
Jeff Layton
- next: ltp: fs: read_all: block sda: the capability attribute has been deprecated. - supervisor instruction fetch in kernel mode,
Naresh Kamboju
- [PATCH v4] mm/page_alloc: fix min_free_kbytes calculation regarding ZONE_MOVABLE,
liuq
- [linux-next:master 6157/11436] drivers/gpu/drm/i915/soc/intel_gmch.c:41:13: warning: variable 'mchbar_addr' set but not used, kernel test robot
- [PATCH] mm/page_alloc: Use write_seqlock_irqsave() instead write_seqlock() + local_irq_save().,
Sebastian Andrzej Siewior
- [linux-next:master 9707/11436] lcs.c:undefined reference to `fddi_type_trans', kernel test robot
- [linux-next:master 11012/11071] drivers/irqchip/irq-mxs.c:12:10: fatal error: 'linux/irqchip/mxs.h' file not found, kernel test robot
- [PATCH] mm: zswap: fix double invalidate with exclusive loads,
Yosry Ahmed
- [PATCH v3] mm/min_free_kbytes: modify min_free_kbytes calculation rules,
liuq
- [PATCH 08/11] sysctl: Add size to register_sysctl_init,
Joel Granados
- [linux-next:master 11060/11436] block/genhd.c:369:51: sparse: sparse: restricted blk_mode_t degrades to integer, kernel test robot
- [PATCH] mm: page_alloc: use the correct type of list for free pages,
Baolin Wang
- [PATCH v2] mm/min_free_kbytes: modify min_free_kbytes calculation rules,
liuq
- [PATCH v20 0/5] Implement IOCTL to get and optionally clear info about PTEs,
Muhammad Usama Anjum
- Re: [RFC PATCH v0 1/3] sched/numa: Process based autonuma scan period framework, Raghavendra K T
- [PATCH 2/2] mm/vmscan: fix root proactive reclaim unthrottling unbalanced node, Yosry Ahmed
- [PATCH 1/2] mm: memcg: rename and document global_reclaim(),
Yosry Ahmed
- [PATCH 0/2] memory.reclaim fixes for root cgroup, Yosry Ahmed
- [PATCH 1/3] mm: change vma_start_read to fail if VMA got detached from under it,
Suren Baghdasaryan
- [stable:linux-5.15.y 36/9999] fs/gfs2/rgrp.c:994:12: warning: stack frame size (1056) exceeds limit (1024) in 'gfs2_ri_update', kernel test robot
- [linux-next:master 7728/11071] kernel/rcu/rcuscale.c:301:27: error: 'get_rcu_tasks_gp_kthread' undeclared here (not in a function); did you mean 'get_rcu_tasks_trace_gp_kthread'?,
kernel test robot
- [linux-next:master 2819/11071] fs/ceph/addr.c:794:12: warning: stack frame size (2096) exceeds limit (2048) in 'ceph_writepages_start',
kernel test robot
- [PATCH v3] mm: zswap: multiple zpools support,
Yosry Ahmed
- [GIT PULL] hotfixes against 6.4-rc7,
Andrew Morton
- [linux-next:master 8789/11071] kernel/bpf/verifier.c:3959:12: warning: stack frame size (2144) exceeds limit (2048) in '__mark_chain_precision', kernel test robot
- [PATCH] mm: backing-dev: make bdi_class a static const structure, Greg Kroah-Hartman
- [PATCH net-next v3 00/18] splice, net: Switch over users of sendpage() and remove it,
David Howells
- [PATCH net-next v3 02/18] net: Display info about MSG_SPLICE_PAGES memory handling in proc, David Howells
- [PATCH net-next v3 05/18] ceph: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage, David Howells
- [PATCH net-next v3 06/18] net: Use sendmsg(MSG_SPLICE_PAGES) not sendpage in skb_send_sock(), David Howells
- [PATCH net-next v3 04/18] siw: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage to transmit, David Howells
- [PATCH net-next v3 01/18] net: Copy slab data for sendmsg(MSG_SPLICE_PAGES), David Howells
- [PATCH net-next v3 08/18] rds: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage, David Howells
- [PATCH net-next v3 11/18] nvme/target: Use sendmsg(MSG_SPLICE_PAGES) rather then sendpage, David Howells
- [PATCH net-next v3 09/18] dlm: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage, David Howells
- [PATCH net-next v3 12/18] smc: Drop smc_sendpage() in favour of smc_sendmsg() + MSG_SPLICE_PAGES, David Howells
- [PATCH net-next v3 07/18] ceph: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage(), David Howells
- [PATCH net-next v3 03/18] tcp_bpf, smc, tls, espintcp: Reduce MSG_SENDPAGE_NOTLAST usage, David Howells
- [PATCH net-next v3 15/18] drdb: Send an entire bio in a single sendmsg, David Howells
- [PATCH net-next v3 16/18] iscsi: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage, David Howells
- [PATCH net-next v3 13/18] ocfs2: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage(), David Howells
- [PATCH net-next v3 10/18] nvme/host: Use sendmsg(MSG_SPLICE_PAGES) rather then sendpage, David Howells
- [PATCH net-next v3 14/18] drbd: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage(), David Howells
- [PATCH net-next v3 18/18] net: Kill MSG_SENDPAGE_NOTLAST, David Howells
- [PATCH v2 0/2] send tlb_remove_table_smp_sync IPI only to necessary CPUs,
Yair Podemsky
- [linux-next:master 9692/11071] drivers/s390/net/lcs.c:2150: undefined reference to `fddi_type_trans', kernel test robot
- [PATCH v7 00/19] mm: ioremap: Convert architectures to take GENERIC_IOREMAP way,
Baoquan He
- [PATCH v7 02/19] hexagon: mm: Convert to GENERIC_IOREMAP, Baoquan He
- [PATCH v7 01/19] asm-generic/iomap.h: remove ARCH_HAS_IOREMAP_xx macros, Baoquan He
- [PATCH v7 04/19] mm/ioremap: Define generic_ioremap_prot() and generic_iounmap(), Baoquan He
- [PATCH v7 03/19] openrisc: mm: remove unneeded early ioremap code, Baoquan He
- [PATCH v7 05/19] mm: ioremap: allow ARCH to have its own ioremap method definition, Baoquan He
- [PATCH v7 06/19] mm/ioremap: add slab availability checking in ioremap_prot, Baoquan He
- [PATCH v7 08/19] ia64: mm: Convert to GENERIC_IOREMAP, Baoquan He
- [PATCH v7 09/19] openrisc: mm: Convert to GENERIC_IOREMAP, Baoquan He
- [PATCH v7 07/19] arc: mm: Convert to GENERIC_IOREMAP, Baoquan He
- [PATCH v7 10/19] s390: mm: Convert to GENERIC_IOREMAP, Baoquan He
- [PATCH v7 11/19] sh: add <asm-generic/io.h> including, Baoquan He
- [PATCH v7 13/19] xtensa: mm: Convert to GENERIC_IOREMAP, Baoquan He
- [PATCH v7 14/19] parisc: mm: Convert to GENERIC_IOREMAP, Baoquan He
- [PATCH v7 12/19] sh: mm: Convert to GENERIC_IOREMAP, Baoquan He
- [PATCH v7 16/19] mm: move is_ioremap_addr() into new header file, Baoquan He
- [PATCH v7 15/19] mm/ioremap: Consider IOREMAP space in generic ioremap, Baoquan He
- [PATCH v7 17/19] powerpc: mm: Convert to GENERIC_IOREMAP, Baoquan He
- [PATCH v7 19/19] mm: ioremap: remove unneeded ioremap_allowed and iounmap_allowed, Baoquan He
- [PATCH v7 18/19] arm64 : mm: add wrapper function ioremap_prot(), Baoquan He
- [6.4.0-rc7-next-20230620] Boot failure on IBM Power LPAR,
Sachin Sant
- [RFC PATCH 0/2] Invalidate secondary IOMMU TLB on permission upgrade,
Alistair Popple
- [PATCH] scripts/gdb: fix 'lx-lsmod' show the wrong size,
Kuan-Ying Lee
- [PATCH v2 00/12] mm: free retracted page table by RCU,
Hugh Dickins
- [PATCH v2 01/12] mm/pgtable: add rcu_read_lock() and rcu_read_unlock()s, Hugh Dickins
- [PATCH v2 02/12] mm/pgtable: add PAE safety to __pte_offset_map(), Hugh Dickins
- [PATCH v2 03/12] arm: adjust_pte() use pte_offset_map_nolock(), Hugh Dickins
- [PATCH v2 04/12] powerpc: assert_pte_locked() use pte_offset_map_nolock(), Hugh Dickins
- [PATCH v2 05/12] powerpc: add pte_free_defer() for pgtables sharing page, Hugh Dickins
- [PATCH v2 06/12] sparc: add pte_free_defer() for pte_t *pgtable_t, Hugh Dickins
- [PATCH v2 07/12] s390: add pte_free_defer() for pgtables sharing page, Hugh Dickins
- [PATCH v2 08/12] mm/pgtable: add pte_free_defer() for pgtable as page, Hugh Dickins
- [PATCH v2 09/12] mm/khugepaged: retract_page_tables() without mmap or vma lock, Hugh Dickins
- [PATCH v2 10/12] mm/khugepaged: collapse_pte_mapped_thp() with mmap_read_lock(), Hugh Dickins
- [PATCH v2 11/12] mm/khugepaged: delete khugepaged_collapse_pte_mapped_thps(), Hugh Dickins
- [PATCH v2 12/12] mm: delete mmap_write_trylock() and vma_try_start_write(), Hugh Dickins
- [linux-next:master] [scsi] eca2040972: ltp.ioprio_set03.fail,
kernel test robot
- [linux-next:master] BUILD REGRESSION 47045630bc409ce6606d97b790895210dd1d517d, kernel test robot
- [linux-next:master] [splice, net] 2dc334f1a6: netperf.Throughput_Mbps 29.9% improvement, kernel test robot
- [PATCH] mm/memory_hotplug.c: don't fail hot unplug quite so eagerly,
John Hubbard
- [PATCH v2 02/11] selftests/mm: fix unused variable warnings in hugetlb-madvise.c, migration.c, John Hubbard
- [PATCH v2 03/11] selftests/mm: fix "warning: expression which evaluates to zero..." in mlock2-tests.c, John Hubbard
- [PATCH v2 07/11] selftests/mm: fix a "possibly uninitialized" warning in pkey-x86.h, John Hubbard
- [PATCH v2 00/11] A minor flurry of selftest/mm fixes, John Hubbard
- [PATCH v2 01/11] selftests/mm: fix uffd-stress unused function warning, John Hubbard
- [PATCH v2 04/11] selftests/mm: fix invocation of tests that are run via shell scripts, John Hubbard
- [PATCH v2 10/11] selftests/mm: move uffd* routines from vm_util.c to uffd-common.c, John Hubbard
- [PATCH v2 08/11] selftests/mm: fix uffd-unit-tests.c build failure due to missing MADV_COLLAPSE, John Hubbard
- [PATCH v2 06/11] selftests/mm: fix two -Wformat-security warnings in uffd builds, John Hubbard
- Re: [PATCH] mm/memory_hotplug.c: don't fail hot unplug quite so eagerly, David Hildenbrand
- [PATCH drm-next v5 00/14] [RFC] DRM GPUVA Manager & Nouveau VM_BIND UAPI,
Danilo Krummrich
- [PATCH drm-next v5 01/14] drm: execution context for GEM buffers v4, Danilo Krummrich
- [PATCH drm-next v5 02/14] maple_tree: split up MA_STATE() macro, Danilo Krummrich
- [PATCH drm-next v5 04/14] drm: debugfs: provide infrastructure to dump a DRM GPU VA space, Danilo Krummrich
- [PATCH drm-next v5 03/14] drm: manager to keep track of GPUs VA mappings, Danilo Krummrich
- [PATCH drm-next v5 05/14] drm/nouveau: new VM_BIND uapi interfaces, Danilo Krummrich
- [PATCH drm-next v5 06/14] drm/nouveau: get vmm via nouveau_cli_vmm(), Danilo Krummrich
- [PATCH drm-next v5 07/14] drm/nouveau: bo: initialize GEM GPU VA interface, Danilo Krummrich
- [PATCH drm-next v5 08/14] drm/nouveau: move usercopy helpers to nouveau_drv.h, Danilo Krummrich
- [PATCH drm-next v5 09/14] drm/nouveau: fence: separate fence alloc and emit, Danilo Krummrich
- [PATCH drm-next v5 10/14] drm/nouveau: fence: fail to emit when fence context is killed, Danilo Krummrich
- [PATCH drm-next v5 11/14] drm/nouveau: chan: provide nouveau_channel_kill(), Danilo Krummrich
- [PATCH drm-next v5 12/14] drm/nouveau: nvkm/vmm: implement raw ops to manage uvmm, Danilo Krummrich
- [PATCH drm-next v5 14/14] drm/nouveau: debugfs: implement DRM GPU VA debugfs, Danilo Krummrich
- [PATCH drm-next v5 13/14] drm/nouveau: implement new VM_BIND uAPI, Danilo Krummrich
- Re: [PATCH drm-next v5 00/14] [RFC] DRM GPUVA Manager & Nouveau VM_BIND UAPI, Danilo Krummrich
- Re: [PATCH drm-next v5 00/14] [RFC] DRM GPUVA Manager & Nouveau VM_BIND UAPI, Boris Brezillon
- [PATCH v2 0/8] mm/gup: Unify hugetlb, speed up thp,
Peter Xu
- [linux-next:master 10783/10788] /bin/bash: line 1: 137480 Segmentation fault LLVM_OBJCOPY="llvm-objcopy" pahole -J --btf_gen_floats -j --lang_exclude=rust --skip_encoding_btf_inconsistent_proto --btf_gen_optimized --btf_base vmlinux drivers/iio/adc/max1363.ko, kernel test robot
- [PATCH mm-unstable v1] mm/mglru: make memcg_lru->lock irq safe,
Yu Zhao
- [PATCH] mm/gup: Do not return 0 from pin_user_pages_fast() for bad args,
Jason Gunthorpe
- [syzbot] [mm?] inconsistent lock state in lru_gen_rotate_memcg,
syzbot
- [syzbot] [mm?] linux-next boot error: kernel BUG in do_vmi_align_munmap, syzbot
- [PATCH v1 0/2] Add obj allocated counter for subpages,
Alexey Romanov
- [PATCH] selftests: cgroup: fix unexpected failure on test_memcg_sock, Haifeng Xu
- [linux-next:pending-fixes] BUILD SUCCESS dab158ce7741dadc666c660810004988e8ca6ea6, kernel test robot
- [PATCH -next v2 1/2] mm: compaction: convert to use a folio in isolate_migratepages_block(),
Kefeng Wang
- [PATCH v2] mm: Fix shmem THP counters on migration,
Jan Glauber
- [PATCH] kasan: fix mention for KASAN_HW_TAGS,
Chanho Min
- [linux-next:master 10734/10788] arch/riscv/kvm/aia_imsic.c:237:9: error: call to undeclared function 'arch_atomic_long_fetch_or'; ISO C99 and later do not support implicit function declarations, kernel test robot
- [PATCH V2] x86,NUMA:improve the execution efficiency of numa_meminfo_cover_memory(),
Liam Ni
- [PATCH] mm: Fix shmem THP counters on migration,
Jan Glauber
- [PATCH] selftests/cgroup: allow running a specific test with test_memcontrol,
Yosry Ahmed
- [PATCH] mm/sparse: Check the return value of first_present_section_nr(),
Liam Ni
- [PATCH v4] mm: pass nid to reserve_bootmem_region(),
Yajun Deng
- [PATCH v4] mm: compaction: skip memory hole rapidly when isolating migratable pages, Baolin Wang
- [linux-next:master 8123/10546] ERROR: modpost: "ip_send_check" [drivers/net/ethernet/sfc/sfc.ko] undefined!, kernel test robot
- [RFC PATCH 5/5] Revert "mm/migrate: __unmap_and_move() push good newpage to LRU",
Yosry Ahmed
- [RFC PATCH 4/5] mm/vmscan: revive the unevictable LRU, Yosry Ahmed
- [RFC PATCH 3/5] mm/mlock: WARN_ON() if mapcount overflows into mlock_count, Yosry Ahmed
- [RFC PATCH 2/5] mm/mlock: fixup mlock_count during unmap, Yosry Ahmed
- [RFC PATCH 1/5] mm/mlock: rework mlock_count to use _mapcount for order-0 folios,
Yosry Ahmed
- [RFC PATCH 0/5] mm/mlock: new mlock_count tracking scheme, Yosry Ahmed
- [PATCH v3] mm: pass nid to reserve_bootmem_region(),
Yajun Deng
- reference counting gcc plugin,
Aravind Ceyardass
- [linux-next:master 8122/10546] drivers/net/ethernet/sfc/tc_encap_actions.c:144:7: warning: variable 'n' is used uninitialized whenever 'if' condition is true, kernel test robot
- [linux-next:master 5707/10546] drivers/gpu/drm/i915/i915_driver.c:1806:24: error: 'i915_drm_client_fdinfo' undeclared here (not in a function); did you mean 'i915_drm_client_alloc'?, kernel test robot
- [linux-next:master 8257/10546] drivers/infiniband/hw/bnxt_re/qplib_rcfw.c:325:18: warning: variable 'opcode' is uninitialized when used here, kernel test robot
- [PATCH net-next v2 17/17] net: Kill MSG_SENDPAGE_NOTLAST,
David Howells
- [PATCH net-next v2 15/17] iscsi: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage, David Howells
- [PATCH net-next v2 14/17] drdb: Send an entire bio in a single sendmsg, David Howells
- [PATCH net-next v2 13/17] drbd: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage(), David Howells
- [PATCH net-next v2 12/17] ocfs2: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage(), David Howells
- [PATCH net-next v2 11/17] smc: Drop smc_sendpage() in favour of smc_sendmsg() + MSG_SPLICE_PAGES, David Howells
- [PATCH net-next v2 10/17] nvme: Use sendmsg(MSG_SPLICE_PAGES) rather then sendpage,
David Howells
- [PATCH net-next v2 09/17] dlm: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage, David Howells
- [PATCH net-next v2 08/17] rds: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage, David Howells
- [PATCH net-next v2 07/17] ceph: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage(), David Howells
- [PATCH net-next v2 06/17] net: Use sendmsg(MSG_SPLICE_PAGES) not sendpage in skb_send_sock(), David Howells
- [PATCH net-next v2 05/17] ceph: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage, David Howells
- [PATCH net-next v2 04/17] siw: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage to transmit, David Howells
- [PATCH net-next v2 02/17] net: Display info about MSG_SPLICE_PAGES memory handling in proc, David Howells
- [PATCH net-next v2 03/17] tcp_bpf, smc, tls, espintcp: Reduce MSG_SENDPAGE_NOTLAST usage, David Howells
- [PATCH net-next v2 01/17] net: Copy slab data for sendmsg(MSG_SPLICE_PAGES),
David Howells
[Index of Archives]
[Linux Kernel Development]
[Linux ARM Kernel]
[Linux MIPS]
[Linux S390]
[Bugtraq]
[Fedora ARM]