Why should we add so many interfaces for memory hotplug emulation? If so, we should create both sysfs and debugfs entries for an online node, we are trying to add redundant code logic. We need not make a simple thing such complicated, Simple is beautiful, I'd prefer to rename the mem_hotplug/probe interface as mem_hotplug/add_memory. /sys/kernel/debug/mem_hotplug/add_node (already exists) /sys/kernel/debug/mem_hotplug/add_memory (rename probe as add_memory) Thanks & Regards, Shaohui -----Original Message----- From: David Rientjes [mailto:rientjes@xxxxxxxxxx] Sent: Thursday, December 02, 2010 10:13 AM To: Zheng, Shaohui Cc: Andrew Morton; linux-mm@xxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx; lethal@xxxxxxxxxxxx; Andi Kleen; Dave Hansen; Greg KH; Li, Haicheng Subject: Re: [8/8, v6] NUMA Hotplug Emulator: implement debugfs interface for memory probe On Thu, 2 Dec 2010, Shaohui Zheng wrote: > so we should still keep the sysfs memory/probe interface without any modifications, > but for the debugfs mem_hotplug/probe interface, we can add the memory region > to a desired node. This feature would be distinct from the add_node interface already provided: instead of hotplugging a new node to test the memory hotplug callbacks, this new interface would only be hotadding new memory to a node other than the one it has physical affinity with. For that support, I'd suggest new probe files in debugfs for each online node: /sys/kernel/debug/mem_hotplug/add_node (already exists) /sys/kernel/debug/mem_hotplug/node0/add_memory /sys/kernel/debug/mem_hotplug/node1/add_memory ... and then you can offline and remove that memory with the existing hotplug support (CONFIG_MEMORY_HOTPLUG and CONFIG_MEMORY_HOTREMOVE, respectively). -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxxx For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom policy in Canada: sign http://dissolvethecrtc.ca/ Don't email: <a href