On 27.7.2011 15:31, Arnaud Lacombe wrote:
Hi,
On Wed, Jul 27, 2011 at 4:36 AM, Michal Marek<mmarek@xxxxxxx> wrote:
On 27.7.2011 06:35, Randy Dunlap wrote:
On Tue, 26 Jul 2011 20:42:04 -0400 Arnaud Lacombe wrote:
On Tue, Jul 26, 2011 at 2:48 PM, Arnaud Lacombe<lacombar@xxxxxxxxx>
wrote:
On Tue, Jul 26, 2011 at 2:28 PM, Randy Dunlap<rdunlap@xxxxxxxxxxxx>
wrote:
I guess I prefer your ENABLED() syntax then.
we need to be careful about namespace pollution/collision.
For the sake of having numbers:
% git grep -w ENABLED . | wc -l
116
% git grep -w CONFIGURED . | wc -l
11
% git grep -w KCONFIG . | wc -l
1
OK. Then I would go back to a predicate like the original patch had,
e.g.:
IS_ENABLED(CONFIG_NUMA)
Good idea. Is anyone against
IS_ENABLED(CONFIG_FOO)
IS_ENABLED_BUILTIN(CONFIG_FOO)
IS_ENABLED_MODULE(CONFIG_FOO)
?
I'm good with the naming, but how would you define those ? I may have
trouble to discern between IS_ENABLED() and IS_ENABLED_BUILTIN().
IS_ENABLED() would mean not disabled, i.e. either 'y' or 'm'.
IS_ENABLED_BUILTIN() would mean 'y' and only 'y' and IS_ENABLED_MODULE()
would mean 'm'. For boolean options, IS_ENABLED() would be equivalent to
IS_ENABLED_BUILTIN() and IS_ENABLED_MODULE() would be always false.
Michal
--
To unsubscribe from this list: send the line "unsubscribe linux-kbuild" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html