On 17/08/16 05:01, Matt Ranostay wrote: > On Sat, Jul 30, 2016 at 10:11 PM, Matt Ranostay <mranostay@xxxxxxxxx> wrote: >> Now there are channel modifiers with their own scaling those should be >> used when possible over the generic channel type scaling. >> >> Cc: Marek Vasut <marex@xxxxxxx> >> Cc: Jonathan Cameron <jic23@xxxxxxxxxx> >> Signed-off-by: Matt Ranostay <mranostay@xxxxxxxxx> > > Jonathan, > > Know you are probably still digging out your inbox since your holiday. > Any comments on this one? > Indeed - still not caught up. Was hoping for space on the plane, but of course despite it being the middle of the day the person in front of me immediately put their chair fully back. Laptop too big to fit at that point! Jonathan > Thanks, > > Matt > >> --- >> tools/iio/iio_utils.c | 11 +++++++---- >> 1 file changed, 7 insertions(+), 4 deletions(-) >> >> diff --git a/tools/iio/iio_utils.c b/tools/iio/iio_utils.c >> index 5eb6793f3972..7a6d61c6c012 100644 >> --- a/tools/iio/iio_utils.c >> +++ b/tools/iio/iio_utils.c >> @@ -121,10 +121,6 @@ int iioutils_get_type(unsigned *is_signed, unsigned *bytes, unsigned *bits_used, >> >> ret = -ENOENT; >> while (ent = readdir(dp), ent) >> - /* >> - * Do we allow devices to override a generic name with >> - * a specific one? >> - */ >> if ((strcmp(builtname, ent->d_name) == 0) || >> (strcmp(builtname_generic, ent->d_name) == 0)) { >> ret = asprintf(&filename, >> @@ -178,6 +174,13 @@ int iioutils_get_type(unsigned *is_signed, unsigned *bytes, unsigned *bits_used, >> sysfsfp = 0; >> free(filename); >> filename = 0; >> + >> + /* >> + * Avoid having a more generic entry overwriting >> + * the settings. >> + */ >> + if (strcmp(builtname, ent->d_name) == 0) >> + break; >> } >> >> error_close_sysfsfp: >> -- >> 2.7.4 >> -- To unsubscribe from this list: send the line "unsubscribe linux-iio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html