Re: [PATCH RESEND] iio: iio-utils: use channel modifier scaling if it exists

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 19/08/16 21:44, Matt Ranostay wrote:
> Now there are channel modifiers with their own scaling those should be
> used when possible over the generic channel type scaling.
Fine in general.

Example though for this intro please.

Makes it easier to follow through the changes in the patch.

Thanks,

Jonathan
> 
> Signed-off-by: Matt Ranostay <mranostay@xxxxxxxxx>
> ---
>  tools/iio/iio_utils.c | 11 +++++++----
>  1 file changed, 7 insertions(+), 4 deletions(-)
> 
> diff --git a/tools/iio/iio_utils.c b/tools/iio/iio_utils.c
> index 5eb6793f3972..7a6d61c6c012 100644
> --- a/tools/iio/iio_utils.c
> +++ b/tools/iio/iio_utils.c
> @@ -121,10 +121,6 @@ int iioutils_get_type(unsigned *is_signed, unsigned *bytes, unsigned *bits_used,
>  
>  	ret = -ENOENT;
>  	while (ent = readdir(dp), ent)
> -		/*
> -		 * Do we allow devices to override a generic name with
> -		 * a specific one?
> -		 */
>  		if ((strcmp(builtname, ent->d_name) == 0) ||
>  		    (strcmp(builtname_generic, ent->d_name) == 0)) {
>  			ret = asprintf(&filename,
> @@ -178,6 +174,13 @@ int iioutils_get_type(unsigned *is_signed, unsigned *bytes, unsigned *bits_used,
>  			sysfsfp = 0;
>  			free(filename);
>  			filename = 0;
> +
> +			/*
> +			 * Avoid having a more generic entry overwriting
> +			 * the settings.
> +			 */
> +			if (strcmp(builtname, ent->d_name) == 0)
> +				break;
>  		}
>  
>  error_close_sysfsfp:
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-iio" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Input]     [Linux Kernel]     [Linux SCSI]     [X.org]

  Powered by Linux