Just to be on the same boat, all these comments are against http://people.redhat.com/~dhowells/nfs/nfs+fscache-16.tar.bz2 This mail is just the core-touching paches, the fscache and cachefiles code will get a review of it's own later on. 01-ino64.diff: ACK 02-ino64-nfs.diff: Unfortunately there's a lot of broken userspace that can't deal with 64bit inode numbers, so you need to make the lod behaviour a mount option at least, probably even the default. Given that we're going to run into problems like that it might make sense to make the option VFS-level instead of just in nfs. (Note: XFS already has an option like that) 03-fsmisc.diff: ACK 05-release-page.diff: ACK, though I'd wish someone could come up with nicer names for read_cache_pages_invalidate_page(s). 06-block-afs.diff: ACK. 09-cachefiles-ia64.diff: ACK. (Although I remember at some point I wanted to unify copy_page and copy_highpage) 11-autofs-dcache.diff: ACK. Should probably go in ASAP. 12-reiserfs-dcache.diff: ACK. Again should probably go in ASAP. Note that reiserfs_kill_sb could be written a lot nicer by using a local variable. static void reiserfs_kill_sb(struct super_block *sb) { struct reiserfs_sb_info *si = REISERFS_SB(s); if (si) { if (si->xattr_root) { d_invalidate(si->xattr_root); dput(si->xattr_root); } if (si->priv_root) { d_invalidate(si->priv_root); dput(si->priv_root); } } kill_block_super(sb); } 13-dcache-crunch.diff: I know Jan has been rather unhappy with this, and I tend to agree to at least the code duplication part. I wish I had time to look into a better way to implement the rather nice idea behind shrink_dcache_for_umount. Why is this patch required for fscache anyway? (and why is it last in the series then?) - To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html