On 03/14, Melissa Wen wrote: > On 03/13, Arthur Grillo wrote: > > > > > > On 12/03/24 15:27, Melissa Wen wrote: > > > On 03/06, Arthur Grillo wrote: > > >> As well noted by Pekka[1], the rounding of drm_fixp2int_round is wrong. > > >> To round a number, you need to add 0.5 to the number and floor that, > > >> drm_fixp2int_round() is adding 0.0000076. Make it add 0.5. > > >> > > >> [1]: https://lore.kernel.org/all/20240301135327.22efe0dd.pekka.paalanen@xxxxxxxxxxxxx/ > > >> > > > Hi Arthur, > > > > > > thanks for addressing this issue. > > > > > > Please, add a fix tag to the commit that you are fixing, so we can > > > easily backport. Might be this commit: > > > https://cgit.freedesktop.org/drm/drm-misc/commit/drivers/gpu/drm/vkms?id=ab87f558dcfb2562c3497e89600dec798a446665 > > >> Suggested-by: Pekka Paalanen <pekka.paalanen@xxxxxxxxxxxxx> > > >> Signed-off-by: Arthur Grillo <arthurgrillo@xxxxxxxxxx> > > >> --- > > >> include/drm/drm_fixed.h | 2 +- > > >> 1 file changed, 1 insertion(+), 1 deletion(-) > > >> > > >> diff --git a/include/drm/drm_fixed.h b/include/drm/drm_fixed.h > > >> index 0c9f917a4d4b..de3a79909ac9 100644 > > >> --- a/include/drm/drm_fixed.h > > >> +++ b/include/drm/drm_fixed.h > > >> @@ -90,7 +90,7 @@ static inline int drm_fixp2int(s64 a) > > >> > > >> static inline int drm_fixp2int_round(s64 a) > > >> { > > >> - return drm_fixp2int(a + (1 << (DRM_FIXED_POINT_HALF - 1))); > > > Also, this is the only usage of DRM_FIXED_POINT_HALF. Can you also > > > remove it as it won't be used anymore? > > > > > >> + return drm_fixp2int(a + DRM_FIXED_ONE / 2); > > > Would this division be equivalent to just shifting 1ULL by 31 instead of > > > 32 as done in DRM_FIXED_ONE? > > > > Yes, but I think the division makes it easier to understand what is > > going on. > > Right. I was thinking about slightly better performance, but I don't > have any data. We can go with this since you consider more readable, > anyway. Just checked that Harry proposed in another patch[1] this: `#define DRM_FIXED_HALF 0x80000000ll` for the 0.5 const Doesn't it sounds better? [1] https://lore.kernel.org/dri-devel/20240226211100.100108-4-harry.wentland@xxxxxxx/ > > Can you send another version addressing the other comments? Then I can > cherry-pick and already apply the fix. > > Thanks, > > Melissa > > > > > Best Regards, > > ~Arthur Grillo > > > > > > > > Melissa > > > > > >> } > > >> > > >> static inline int drm_fixp2int_ceil(s64 a) > > >> > > >> -- > > >> 2.43.0 > > >>