Re: Coolkey use problems on Fedora 14 (no token available)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


My apologies regarding Gentoo. I have a separate thread "Problems accessing ActivIdentity USB SIM under Gentoo Linux 64 bit on Intel"

It may prove useful that in that thread, in the most recent post by myself, I supplied the pcscd -fad output on the same 32 bit system where one instance failed, then I restored the old coolkey binaries, restarted pcscd -fad  and then re-ran the 'pkcs11_inspect' and it worked.

The differences between the two runs are very minor but the main difference seems to be a 'protocol' value changed from 1 to 0.

Feel free to have a look at that. That thread also identifies the patches that Gentoo applies to the base coolkey, as follows :-
The individual patches can be found at a  Gentoo distfiles mirror

On Thu, Feb 10, 2011 at 8:03 AM, Robert Relyea <rrelyea@xxxxxxxxxx> wrote:
On 02/09/2011 12:33 PM, Guy wrote:
> Hi,
> I'm the one who started this thread but it got slightly derailed and
> biased towards gentoo.
> My systems are Opensuse 11.3 and Fedora14 and the problem I have is
> that I do not get prompted for the PIN when issueing either
> pkcs11_inspect or pkcs11_listcerts. I've never seen it work on either
> of these systems. Pcsc_scan works though, it never complains.
This seems to indicate a problem with the pkcs11 module (probably
coolkey). Is the card you are using an actual CAC card, or one of
ActiveCard's 'CAC-Like' (where they use the CAC applet, but issued
through some other agency than DISA).
> My Opensuse 11.3 bears all the latest pcsc-lite, opensc, coolkey, etc
> packages. The Fedora14 system is stock + all automatic updates.
> I run these 2 systems on a Dell Lattitude D830 over the usb port
> (opensuse on a usb disk, fedora on a usb memory stick).
> I plugged the Fedorea usb stick into my home tower pc, with an Asus
> mobo, but the results are the same, so it's not Dell specific.
> My home tower pc runs Opensuse 11.0 natively and there it just works
> fine, I'm asked for the PIN and when supplied I get the certificates
> listed.
> The coolkey package, version 1.1.0-79.1, dates from June 2008.
Thanks, this is helpful. How many certs does your card have?

> Gtz,
> Guy.

Coolkey-devel mailing list


Coolkey-devel mailing list

[Index of Archives]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Women]

  Powered by Linux