Re: Coolkey use problems on Fedora 14 (no token available)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



I'm the one who started this thread but it got slightly derailed and biased towards gentoo.
My systems are Opensuse 11.3 and Fedora14 and the problem I have is that I do not get prompted for the PIN when issueing either
pkcs11_inspect or pkcs11_listcerts. I've never seen it work on either of these systems. Pcsc_scan works though, it never complains.

My Opensuse 11.3 bears all the latest pcsc-lite, opensc, coolkey, etc packages. The Fedora14 system is stock + all automatic updates.
I run these 2 systems on a Dell Lattitude D830 over the usb port (opensuse on a usb disk, fedora on a usb memory stick).
I plugged the Fedorea usb stick into my home tower pc, with an Asus mobo, but the results are the same, so it's not Dell specific.

My home tower pc runs Opensuse 11.0 natively and there it just works fine, I'm asked for the PIN and when supplied I get the certificates listed.
The coolkey package, version 1.1.0-79.1, dates from June 2008.


Op 09-02-11 03:40, Steve Arnold schreef:
On Tue, 08 Feb 2011 12:00:06 -0500 Lyall Pearce wrote:


I guess I should mention that coolkey-1.1.0-r1 (gentoo speak)
worked and every other release after that didn't. Luckily, I have
a binary backup as the gentoo ebuild is no longer available.

Unluckily, that is a 32 bit backup and my 64 bit system is
relatively new, and so, does not work.

Note that earlier Gentoo coolkey ebuilds worked with the old CACs,
but the coolkey-1.1.0-r3 update was necessary to pick up the latest
RedHat patches for the newer CACs (which is the only change in the
Gentoo package). Since that's all I have to test with, you're kinda
on your own for the other stuff.

When submitting bug reports, I'd recommend going straight to
RedHat, and if you want to get my attention, feel free to file a
Gentoo bug with the RedHat bug # etc.

As of just the last few days, there seems to be an issue (on
several of my Gentoo systems) with coolkey and firefox now;
although pcsc_scan sees the card as normal, firefox now refuses to
display a window when I have my CAC reader and card inserted (if I
unplug it everything works normally).  Still trying to figure that
one out...


Coolkey-devel mailing list

Coolkey-devel mailing list

[Index of Archives]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Women]

  Powered by Linux