Virtual Desktop

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi there:

I am hoping someone out there is running X with an a22p laptop using the r128 driver. I am using XFree 4.2.1 and I am only running Linux on the laptop.

I did:

XF86Config -configure

and I got a working XFree86 at 1600x1200. I tried to change it to 1280x1024 lower resolution to no avail.

I keep getting horizontal scroll down the middle of the screen.

Here is my /etc/X11/XF86Config:

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
End Section

Section "Files"
RgbPath "/usr/X11R6/lib/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"

Section "Module"
Load "extmod"
Load "xie"
Load "pex5"
Load "dri"
Load "dbe"
Load "record"
Load "xtrap"
Load "glx"
Load "speedo"
Load "type1"

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "dev/psaux"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30-100
VertRefresh 50-150

Section "Device"
###Available Driver options are:-
###Values: <i>: integer. <f>:float. <bool>: "True"/"False"
###<string>: "String". <freq>: "<f> Hz/kHz/MHz"
#Option "NoAccel" #[<bool>]
#Option "SMcursor" #[<bool>]
#Option "Dac6Bit" #[<bool>]
#Option "Dac8Bit" #[<bool>]
#Option "ForcePCIMode" #[<bool>]
#Option "CCEPIOMode" #[<bool>]
#Option "CCNoSecurity" #[<bool>]
#Option "AGPMode" #<i>
#Option "AGPSize" #<i>
#Option "RingSize" #<i>
#Option "BufferSize" #<i>
#Option "Display" #<str>
#Option "PanelWidth" #<i>
#Option "PanelHeight" #<i>
#Option "ProgramFPRegs"#<i>
#Option "UseFBDev" #[<bool>]
#Option "VideoKey" #<i>
#Option "ShowCache" #[<bool>]
Identifier "Card0"
Driver "ati"
VendorName "ATI"
BoardName "Rage 128 Mobility LF"
BusID "PCI:1:0:0"

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024"
ViewPort 0 0

From /var/log/XFree86.0.log:
(**) R128(0): Default mode "1280x1024": 162.0 MHz, 85.6 kHz, 79.7 Hz
(II) R128(0):Modeline "1280x1024" 162.00 1280 1344 1368 1840 1024 1026 1029 1074 +hsync +vsync
(==) R128(0): DPI set to (75,75)

What I did:

1) I increased vertrefresh to 50-100 from 60-100 and I stopped getting vertrefresh out of range error messages.
2) I added ViewPort 0 0 under the Section Screen to force that resolution as the virtual desktop.
3) I tried listing Modes "1600x1200" "1280x1024"and tried switching using to get the 1280x1024 resolution CTRL-ALT- - (from the numeric pad & keyboard) that didn't work
4) I tried changing Panel Width to "1280" and Panel Length "1024" and I got a screwy screen.
5)I changed Modes back to "1280x1024" and still got the scrolling vertrefresh lines vertically across the screen
6)I then added under the section "Monitor"

UseModes "Modes0"

and then created a new section "Modes"

Section "Modes"
Identifier "Modes0"
Modeline "1280x1024" 162.00 1280 1344 1368 1840 1024 1026 1029 1074

7) I looked at man vidtune but it says it is obsolete with xfree86 4x

Does anyone have any suggestions?

Sorry for the long email...

Tired of spam? Get advanced junk mail protection with MSN 8.


*** To unsubscribe , or change message options, see:

[Index of Archives]     [XFree86]     [Xfree86 Xpert]     []     [IETF Annouce]     [Security]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Picture Sharing]     [Linux Security]     [Linux RAID]

  Powered by Linux