X locks up the complete system

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I am running Mandrake 9.0 distro and the X server 4.2.1 which came with
it. The problem is that, after using X for some time, my system locks up
completely. I mean no key combination works. No not even the Magic Sysrq.
The only option is a hard reset.
The symptoms:
	1. Mouse pointer disappears.
	2. No common action ( that means, I can't recreate it
intentionally. )
	3. Occurs irrespective of GUI. KDE, Gnome all the same.
	4. Complete system freeze.
	5. May occur within minutes after the boot or after hours.

What I have done:
	1. Executed memtest yesterday and quit it in the 4th round since
it did not show any errors.
	2. Downloaded and installed the latest drivers/modules for my card
(sis_drv.o and sis_dri.so )
	3. Tried increasing the graphics shared memory in bios.
	4. Searched for IRQ conflicts but could not find any.
	5. Disabled v4l in Xfreeconfig file.
	6. Tried disabling glx too. but no change.

The setup:
	1. AMD Duron 800 Mhz.
	2. 128 MB SDRAM.
	3. K7SEM MoBo. Onboard audio and 3D acceleration. SiS730S chipset.
	4. External conventional modem.
	5. LG studioworks 56i 15 inch monitor.
	6. 20 GB western digital HDD.
	7. CD ROM and floppy drives.

When the system is working it works like anything. I mean no cokplains as
long as it is up. Audio is fine. mouse movements and all. everything is
perfect. But only till the system comes to a complete halt. :(.
Please guide me. Its getting on my nerves. By the way, the resolution is
1024x768 @ 16 bpp.

Thanks a lot.


*** To unsubscribe , or change message options, see:

[Index of Archives]     [XFree86]     [Xfree86 Xpert]     [X.org]     [IETF Annouce]     [Security]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Picture Sharing]     [Linux Security]     [Linux RAID]

  Powered by Linux