Recompiling trn (was: Re: trn error!?)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Tue, 26 Nov 2002, Jeremy Nixon wrote:

> I've never seen it before, myself; I had to find the error in the source
> to figure out what it meant.  Unfortunately, if the error isn't still
> happening, there may not be much chance of debugging it... though I bet
> something in the data was confusing one part of trn into thinking it was
> clear to send another command, when it really wasn't (and the rest of
> trn knew it).

If/when it happens again I'll try to find the cause of it.

However, to do this, I tried to compile trn myself (I'm currently using a
version I extracted from a Linux binary release), but I'm running into
some difficulties there.

I'm using my 'own' GNU curses lib (installed into my homedirectory), and
everything compiles OK. However, when linking trn I run into difficulties:

gcc -L/usr/local/lib -L/home/cvs_guest/lib addng.o art.o artio.o artsrch.o
autosub.o backpage.o bits.o cache.o charsubst.o datasrc.o decode.o
edit_dist.o env.o final.o hash.o head.o help.o init.o intrp.o kfile.o
last.o list.o mime.o ng.o ngdata.o ngsrch.o ngstuff.o only.o opt.o rcln.o
rcstuff.o respond.o rthread.o rt-mt.o rt-ov.o rt-process.o rt-page.o
rt-select.o rt-util.o rt-wumpus.o search.o sw.o term.o trn.o util.o
util2.o uudecode.o parsedate.o nntpinit.o nntpclient.o nntpauth.o nntp.o
wildmat.o color.o filter.o scan.o scmd.o sdisp.o smisc.o sorder.o spage.o
scanart.o samain.o samisc.o sadisp.o sacmd.o sadesc.o sathread.o url.o
mempool.o univ.o score.o scorefile.o scoresave.o score-easy.o tkstuff.o
tktree.o -lm -lresolv -lnsl -lncurses -o trn
/home/cvs_guest/lib/libncurses.a(lib_termcap.o)(.data+0x0): multiple
definition of `UP'
term.o(.data+0x14): first defined here
/home/cvs_guest/lib/libncurses.a(lib_termcap.o)(.data+0x4): multiple
definition of `BC'
term.o(.data+0x10): first defined here
/home/cvs_guest/lib/libncurses.a(lib_tputs.o)(.data+0x0): multiple
definition of `PC'
term.o(.data+0x66): first defined here
/home/cvs_guest/lib/libncurses.a(lib_setup.o)(.data+0x4): multiple
definition of `LINES'
term.o(.data+0x70): first defined here
/home/cvs_guest/lib/libncurses.a(lib_setup.o)(.data+0x8): multiple
definition of `COLS'
term.o(.data+0x74): first defined here
collect2: ld returned 1 exit status
make: *** [trn] Error 1

So I tried removing the definition of the offending items from term.h
(brute force, it sometimes works) but that doesn't do it in this case.
This is probably not a trn-specific problem, and the solution is also
straightforward, but I'm not that experienced in compiling stuff,
especially when errors appear. ;)

So what could I do to fix this? Add/remove some includes?

Thanks for the information.

Best regards,


This email is sponsored by: Get the new Palm Tungsten T 
handheld. Power & Color in a compact size!

[Index of Archives]     [Photo]     [Yosemite]     [Epson Inkjet]     [Mhonarc]     [Nntpcache]

  Powered by Linux