Linux Sparc
[Prev Page][Next Page]
- [PATCH 13/15] arch, drivers: replace for_each_membock() with for_each_mem_range(), (continued)
- [PATCH 20/24] sparc: use asm-generic/mmu_context.h for no-op implementations,
Nicholas Piggin
- [PATCH -next] sparc: use for_each_child_of_node() macro,
Qinglang Miao
- [PATCH v2] drm/drm_fb_helper: fix fbdev with sparc64,
Sam Ravnborg
- [PATCH 0/3] Drop unused MAX_PHYSADDR_BITS,
Arvind Sankar
- [PATCH] SPARC: backoff.h: delete a duplicated word,
Randy Dunlap
- [PATCH] sparc32: fix a user-triggerable oops in clear_user(),
Al Viro
- io_uring kthread_use_mm / mmget_not_zero possible abuse,
Nicholas Piggin
- Re: [RFC PATCH 00/35] Move all PCIBIOS* definitions into arch/x86,
Bjorn Helgaas
- [RFC PATCH 23/35] sparc/PCI: Change PCIBIOS_SUCCESSFUL to 0,
Saheed O. Bolarinwa
- [PATCH] arch/sparc: Replace HTTP links with HTTPS ones,
Alexander A. Klimov
- [PATCH] drm/drm_fb_helper: fix fbdev with sparc64,
Sam Ravnborg
- [PATCH v2 0/5] crypto: add sha256() function,
Eric Biggers
- [PATCH v5 20/25] mm/sparc32: Use general page fault accounting,
Peter Xu
- [PATCH v5 21/25] mm/sparc64: Use general page fault accounting,
Peter Xu
- [PATCH][next] sparc: Use fallthrough pseudo-keyword,
Gustavo A. R. Silva
- [PATCH 0/2] genirq: Kill preflow handlers,
Valentin Schneider
- [PATCH] sparc: sparc64_defconfig: add necessary configs for qemu,
Corentin Labbe
- [PATCH v4 20/26] mm/sparc32: Use general page fault accounting,
Peter Xu
- [PATCH v4 21/26] mm/sparc64: Use general page fault accounting,
Peter Xu
- [PATCH 0/8] mm: cleanup usage of <asm/pgalloc.h>,
Mike Rapoport
- [PATCH 1/8] mm: remove unneeded includes of <asm/pgalloc.h>,
Mike Rapoport
- [PATCH 2/8] opeinrisc: switch to generic version of pte allocation,
Mike Rapoport
- [PATCH 3/8] xtensa: switch to generic version of pte allocation,
Mike Rapoport
- [PATCH 4/8] asm-generic: pgalloc: provide generic pmd_alloc_one() and pmd_free_one(),
Mike Rapoport
- [PATCH 5/8] asm-generic: pgalloc: provide generic pud_alloc_one() and pud_free_one(),
Mike Rapoport
- [PATCH 6/8] asm-generic: pgalloc: provide generic pgd_free(),
Mike Rapoport
- [PATCH 7/8] mm: move lib/ioremap.c to mm/,
Mike Rapoport
- [PATCH 8/8] mm: move p?d_alloc_track to separate header file,
Mike Rapoport
- Re: [PATCH 0/8] mm: cleanup usage of <asm/pgalloc.h>,
Matthew Wilcox
- [PATCH 9/8] mm: Account PMD tables like PTE tables,
Matthew Wilcox
- Re: [PATCH 0/8] mm: cleanup usage of <asm/pgalloc.h>,
Pekka Enberg
- Re: [PATCH 0/8] mm: cleanup usage of <asm/pgalloc.h>,
Mike Rapoport
- [PATCH v2 0/2] sparc32: srmmu: improve type safety of __nocache_fix(),
Mike Rapoport
- properly support exec with kernel pointers v3,
Christoph Hellwig
- [PATCH v4 0/8] lockdep: Change IRQ state tracking to use per-cpu variables,
Peter Zijlstra
- [PATCH v4 7/8] lockdep: Change hardirq{s_enabled,_context} to per-cpu variables,
Peter Zijlstra
- [PATCH v4 2/8] x86/entry: Fix NMI vs IRQ state tracking,
Peter Zijlstra
- [PATCH v4 8/8] lockdep: Remove lockdep_hardirq{s_enabled,_context}() argument,
Peter Zijlstra
- [PATCH v4 1/8] lockdep: Prepare for NMI IRQ state tracking,
Peter Zijlstra
- [PATCH v4 4/8] powerpc64: Break asm/percpu.h vs spinlock_types.h dependency,
Peter Zijlstra
- [PATCH v4 6/8] arm: Break cyclic percpu include,
Peter Zijlstra
- [PATCH v4 5/8] s390: Break cyclic percpu include,
Peter Zijlstra
- [PATCH v4 3/8] sparc64: Fix asm/percpu.h build error,
Peter Zijlstra
- [PATCH 02/17] sparc64: enable HAVE_COPY_THREAD_TLS,
Christian Brauner
- [PATCH 04/17] sparc: unconditionally enable HAVE_COPY_THREAD_TLS,
Christian Brauner
- [PATCH 03/17] sparc: share process creation helpers between sparc and sparc64,
Christian Brauner
- Re: mkfs.ext2 - state D partitioning stops at 33% /boot,
Anatoly Pugachev
- [PATCH][next] sparc64: viohs: Use struct_size() helper,
Gustavo A. R. Silva
- [PATCH 20/26] mm/sparc32: Use general page fault accounting,
Peter Xu
- [PATCH 21/26] mm/sparc64: Use general page fault accounting,
Peter Xu
- properly support exec and wait with kernel pointers v2,
Christoph Hellwig
- [PATCH AUTOSEL 5.7 088/388] sparc32: mm: Don't try to free page-table pages if ctor() fails,
Sasha Levin
- [PATCH AUTOSEL 5.4 070/266] sparc32: mm: Don't try to free page-table pages if ctor() fails,
Sasha Levin
- [PATCH] selftests: kvm: don't try to build kvm tests on sparc64 architecture,
Anatoly Pugachev
- [PATCH 22/25] mm/sparc64: Use mm_fault_accounting(),
Peter Xu
- [PATCH 21/25] mm/sparc32: Use mm_fault_accounting(),
Peter Xu
- properly support exec and wait with kernel pointers,
Christoph Hellwig
- Re: Build regressions/improvements in v5.8-rc1,
Geert Uytterhoeven
- Re: [PATCH 04/21] mm: free_area_init: use maximal zone PFNs rather than zone sizes,
Greg Ungerer
- Possible duplicate page fault accounting on some archs after commit 4064b9827063,
Gerald Schaefer
- [PATCH] sparc: piggyback: handle invalid image,
Corentin Labbe
- [PATCH AUTOSEL 5.6 191/606] sparc32: fix page table traversal in srmmu_nocache_init(),
Sasha Levin
- [PATCH AUTOSEL 5.6 190/606] sparc32: use PUD rather than PGD to get PMD in srmmu_nocache_init(),
Sasha Levin
- Fail to build tftpboot.img,
Corentin Labbe
- [PATCH v5 2/3] arch: wire-up close_range(),
Christian Brauner
- [git pull] a couple of sparc ptrace fixes,
Al Viro
- [PATCH v3 0/5] lockdep: Change IRQ state tracking to use per-cpu variables,
Peter Zijlstra
- [PATCH] sparc: remove unused header file nfs_fs.h,
Anupam Aggarwal
- sparc vs sparc64: O_NDELAY and O_NONBLOCK mismatch in kernel and in glibc,
Sergei Trofimovich
- Cache flush issue with page_mapping_file() and swap back shmem page ?,
Jerome Glisse
- [PATCH 0/3] sparc32 SRMMU fixes for SMP,
Will Deacon
- [PATCH] sparc32: register memory occupied by kernel as memblock.memory,
Mike Rapoport
- [PATCH 0/2] sparc32: srmmu: improve type safety of __nocache_fix(),
Mike Rapoport
- Re: [PATCH] sparc32: use PUD rather than PGD to get PMD in srmmu_nocache_init(),
Guenter Roeck
- [PATCH 1/5] silo: Build with -fno-PIC to reduce size,
Matt Turner
- [PATCH] oradax: convert get_user_pages() --> pin_user_pages(),
John Hubbard
- [PATCH v2] Implement close-on-fork,
Nate Karstens
- sort out the flush_icache_range mess v2,
Christoph Hellwig
- [PATCH 01/29] arm: fix the flush_icache_range arguments in set_fiq_handler,
Christoph Hellwig
- [PATCH 02/29] nds32: unexport flush_icache_page,
Christoph Hellwig
- [PATCH 03/29] powerpc: unexport flush_icache_user_range,
Christoph Hellwig
- [PATCH 04/29] unicore32: remove flush_cache_user_range,
Christoph Hellwig
- [PATCH 05/29] asm-generic: fix the inclusion guards for cacheflush.h,
Christoph Hellwig
- [PATCH 06/29] asm-generic: don't include <linux/mm.h> in cacheflush.h,
Christoph Hellwig
- [PATCH 08/29] alpha: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 11/29] hexagon: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 14/29] m68knommu: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 16/29] powerpc: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 17/29] riscv: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 18/29] arm,sparc,unicore32: remove flush_icache_user_range,
Christoph Hellwig
- [PATCH 20/29] asm-generic: add a flush_icache_user_range stub,
Christoph Hellwig
- [PATCH 21/29] sh: implement flush_icache_user_range,
Christoph Hellwig
- [PATCH 22/29] xtensa: implement flush_icache_user_range,
Christoph Hellwig
- [PATCH 25/29] exec: only build read_code when needed,
Christoph Hellwig
- [PATCH 26/29] exec: use flush_icache_user_range in read_code,
Christoph Hellwig
- [PATCH 27/29] binfmt_flat: use flush_icache_user_range,
Christoph Hellwig
- [PATCH 29/29] module: move the set_fs hack for flush_icache_range to m68k,
Christoph Hellwig
- [PATCH 28/29] nommu: use flush_icache_user_range in brk and mmap,
Christoph Hellwig
- [PATCH 24/29] m68k: implement flush_icache_user_range,
Christoph Hellwig
- [PATCH 23/29] arm: rename flush_cache_user_range to flush_icache_user_range,
Christoph Hellwig
- [PATCH 19/29] mm: rename flush_icache_user_range to flush_icache_user_page,
Christoph Hellwig
- [PATCH 12/29] ia64: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 13/29] microblaze: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 15/29] openrisc: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 10/29] c6x: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 07/29] asm-generic: improve the flush_dcache_page stub,
Christoph Hellwig
- [PATCH 09/29] arm64: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 07/11] sparc64: constify sysrq_key_op,
Emil Velikov
- [PATCH 0/3] sparc: port to copy_thread_tls() and struct kernel_clone_args,
Christian Brauner
- sort out the flush_icache_range mess,
Christoph Hellwig
- [PATCH 01/31] arm: fix the flush_icache_range arguments in set_fiq_handler,
Christoph Hellwig
- [PATCH 02/31] arm64: fix the flush_icache_range arguments in machine_kexec,
Christoph Hellwig
- [PATCH 03/31] MIPS: unexport __flush_icache_user_range,
Christoph Hellwig
- [PATCH 04/31] nds32: unexport flush_icache_page,
Christoph Hellwig
- [PATCH 07/31] asm-generic: fix the inclusion guards for cacheflush.h,
Christoph Hellwig
- [PATCH 11/31] arm64: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 12/31] c6x: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 14/31] ia64: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 15/31] microblaze: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 18/31] powerpc: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 19/31] riscv: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 20/31] arm,sparc,unicore32: remove flush_icache_user_range,
Christoph Hellwig
- [PATCH 23/31] sh: implement flush_icache_user_range,
Christoph Hellwig
- [PATCH 24/31] xtensa: implement flush_icache_user_range,
Christoph Hellwig
- [PATCH 21/31] mm: rename flush_icache_user_range to flush_icache_user_page,
Christoph Hellwig
- [PATCH 28/31] exec: use flush_icache_user_range in read_code,
Christoph Hellwig
- [PATCH 29/31] binfmt_flat: use flush_icache_user_range,
Christoph Hellwig
- [PATCH 31/31] module: move the set_fs hack for flush_icache_range to m68k,
Christoph Hellwig
- [PATCH 30/31] nommu: use flush_icache_user_range in brk and mmap,
Christoph Hellwig
- [PATCH 22/31] asm-generic: add a flush_icache_user_range stub,
Christoph Hellwig
- [PATCH 26/31] m68k: implement flush_icache_user_range,
Christoph Hellwig
- [PATCH 27/31] exec: only build read_code when needed,
Christoph Hellwig
- [PATCH 25/31] arm: rename flush_cache_user_range to flush_icache_user_range,
Christoph Hellwig
- [PATCH 06/31] unicore32: remove flush_cache_user_range,
Christoph Hellwig
- [PATCH 05/31] powerpc: unexport flush_icache_user_range,
Christoph Hellwig
- [PATCH 08/31] asm-generic: don't include <linux/mm.h> in cacheflush.h,
Christoph Hellwig
- [PATCH 09/31] asm-generic: improve the flush_dcache_page stub,
Christoph Hellwig
- [PATCH 17/31] openrisc: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 16/31] m68knommu: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 13/31] hexagon: use asm-generic/cacheflush.h,
Christoph Hellwig
- [PATCH 10/31] alpha: use asm-generic/cacheflush.h,
Christoph Hellwig
- Re: sort out the flush_icache_range mess,
Geert Uytterhoeven
- [PATCH -next 0/2] sparc: use snprintf() in show() methods,
Chen Zhou
- [PATCH V3 0/3] mm/hugetlb: Add some new generic fallbacks,
Anshuman Khandual
- [PATCH] sparc64: Replace zero-length array with flexible-array,
Gustavo A. R. Silva
- [PATCH V3 00/15] Remove duplicated kmap code,
ira . weiny
- [PATCH V3 02/15] arch/xtensa: Move kmap build bug out of the way,
ira . weiny
- [PATCH V3 06/15] arch/kmap_atomic: Consolidate duplicate code,
ira . weiny
- [PATCH V3 03/15] arch/kmap: Remove redundant arch specific kmaps,
ira . weiny
- [PATCH V3 05/15] {x86,powerpc,microblaze}/kmap: Move preempt disable,
ira . weiny
- [PATCH V3 14/15] sparc: Remove unnecessary includes,
ira . weiny
- [PATCH V3 01/15] arch/kmap: Remove BUG_ON(),
ira . weiny
- [PATCH V3 15/15] kmap: Consolidate kmap_prot definitions,
ira . weiny
- [PATCH V3 11/15] drm: Remove drm specific kmap_atomic code,
ira . weiny
- [PATCH V3 13/15] parisc/kmap: Remove duplicate kmap code,
ira . weiny
- [PATCH V3 12/15] kmap: Remove kmap_atomic_to_page(),
ira . weiny
- [PATCH V3 07/15] arch/kunmap_atomic: Consolidate duplicate code,
ira . weiny
- Re: [PATCH V3 07/15] arch/kunmap_atomic: Consolidate duplicate code,
Guenter Roeck
- [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
ira . weiny
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Guenter Roeck
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Ira Weiny
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Guenter Roeck
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Ira Weiny
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Ira Weiny
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Guenter Roeck
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Ira Weiny
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Guenter Roeck
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Andrew Morton
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Ira Weiny
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Guenter Roeck
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Mike Rapoport
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Ira Weiny
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Mike Rapoport
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Ira Weiny
- Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice,
Al Viro
- [PATCH V3 09/15] arch/kmap: Don't hard code kmap_prot values,
ira . weiny
- [PATCH V3 08/15] arch/kmap: Ensure kmap_prot visibility,
ira . weiny
- [PATCH V3 10/15] arch/kmap: Define kmap_atomic_prot() for all arch's,
ira . weiny
- [PATCH V3 04/15] arch/kunmap: Remove duplicate kunmap implementations,
ira . weiny
- [PATCH] sparc: mm: return true,false in kern_addr_valid(),
Jason Yan
- [PATCH V2 0/3] mm/hugetlb: Add some new generic fallbacks,
Anshuman Khandual
- Re: [PATCH v2 17/20] mm: free_area_init: allow defining max_zone_pfn in descending order,
Vineet Gupta
- [PATCH V2 00/11] Subject: Remove duplicated kmap code,
ira . weiny
- [PATCH V2 11/11] drm: Remove drm specific kmap_atomic code,
ira . weiny
- [PATCH V2 04/11] arch/kunmap: Remove duplicate kunmap implementations,
ira . weiny
- [PATCH V2 09/11] arch/kmap: Don't hard code kmap_prot values,
ira . weiny
- [PATCH V2 05/11] {x86,powerpc,microblaze}/kmap: Move preempt disable,
ira . weiny
- [PATCH V2 10/11] arch/kmap: Define kmap_atomic_prot() for all arch's,
ira . weiny
- [PATCH V2 08/11] arch/kmap: Ensure kmap_prot visibility,
ira . weiny
- [PATCH V2 06/11] arch/kmap_atomic: Consolidate duplicate code,
ira . weiny
- [PATCH V2 07/11] arch/kunmap_atomic: Consolidate duplicate code,
ira . weiny
- [PATCH V2 03/11] arch/kmap: Remove redundant arch specific kmaps,
ira . weiny
- [PATCH V2 01/11] arch/kmap: Remove BUG_ON(),
ira . weiny
- [PATCH V2 02/11] arch/xtensa: Move kmap build bug out of the way,
ira . weiny
- Re: [PATCH V2 00/11] Subject: Remove duplicated kmap code,
Al Viro
- [PATCH V1 00/10] Remove duplicated kmap code,
ira . weiny
- [PATCH V1 02/10] arch/xtensa: Move kmap build bug out of the way,
ira . weiny
- [PATCH V1 04/10] arch/kunmap: Remove duplicate kunmap implementations,
ira . weiny
- [PATCH V1 07/10] arch/kmap: Ensure kmap_prot visibility,
ira . weiny
- [PATCH V1 08/10] arch/kmap: Don't hard code kmap_prot values,
ira . weiny
- [PATCH V1 09/10] arch/kmap: Define kmap_atomic_prot() for all arch's,
ira . weiny
- [PATCH V1 06/10] arch/kunmap_atomic: Consolidate duplicate code,
ira . weiny
- [PATCH V1 10/10] drm: Remove drm specific kmap_atomic code,
ira . weiny
- [PATCH V1 05/10] arch/kmap_atomic: Consolidate duplicate code,
ira . weiny
- [PATCH V1 03/10] arch/kmap: Remove redundant arch specific kmaps,
ira . weiny
- [PATCH V1 01/10] arch/kmap: Remove BUG_ON(),
ira . weiny
- Re: [PATCH V1 00/10] Remove duplicated kmap code,
Michael Ellerman
- Re: [PATCH V1 00/10] Remove duplicated kmap code,
Christoph Hellwig
- [PATCH v4 0/4] Clean up hugetlb boot command line processing,
Mike Kravetz
- [PATCH -next] sparc64: vcc: Fix error return code in vcc_probe(),
Wei Yongjun
- [PATCH 0/5] Remove duplicated kmap code,
ira . weiny
- Implement close-on-fork,
Nate Karstens
- [PATCHv3 34/50] sparc: Add show_stack_loglvl(),
Dmitry Safonov
- [PATCH v3 0/4] Clean up hugetlb boot command line processing,
Mike Kravetz
- [RESEND PATCH 0/4] Rework sparc32 page-table layout,
Will Deacon
- [PATCH 0/3] mm/hugetlb: Add some new arch enabling macros,
Anshuman Khandual
- Nonworking Ultra45 configuration,
Meelis Roos
- [PATCH] silo: Allow building tilo only,
Matt Turner
- Re: [PATCH 4/5] second: Fix typo'd operator,
Matt Turner
- [PATCH v1] serial: sunhv: Initialize lock for non-registered console,
Andy Shevchenko
- [sparc64] OOPS after 'serial: core: Allow detach and attach serial device for console',
Anatoly Pugachev
- [PATCH v2 0/4] Clean up hugetlb boot command line processing,
Mike Kravetz
- Suspected bug in wait syscall or similar,
Rolf Eike Beer
[Index of Archives]
[Kernel Development]
[Linux ARM Development]
[Linux Resources]
Mail converted by MHonArc