Re: pass "%global" definitions to mock?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 04/10/2016 10:11 AM, Matthias Leopold wrote:

i want to rebuild IUS PHP SRPMs with mock. in the spec file is a
"%global php_bootstrap   0" definition. how can i pass a different value
for "php_bootstrap" to the mock build process? i tried the following:

mock --rebuild --define="php_bootstrap 1" php56u-5.6.20-1.ius.el7.src.rpm

mock --rebuild --define="global php_bootstrap 1"

mock --rebuild php56u-5.6.20-1.ius.el7.src.rpm -r ./test.cfg
test.cfg contains "config_opts['macros']['php_bootstrap'] = "1""

mock --rebuild php56u-5.6.20-1.ius.el7.src.rpm --macro-file=my-macro.txt
my-macro.txt contains "%global php_bootstrap   1"

none of these worked

I don't believe you can. You must edit the spec file. An alternative method would be to do something like

which I believe allows you to pass "--with bootstrap"

Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  orion@xxxxxxxxxxxxx
Boulder, CO 80301    
Rpm-list mailing list

[Index of Archives]     [RPM Ecosystem]     [Linux Kernel]     [Red Hat Install]     [PAM]     [Red Hat Watch]     [Red Hat Development]     [Red Hat]     [Gimp]     [Yosemite News]     [IETF Discussion]

  Powered by Linux