[Sound] RH8.0 No sound

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<


I am using a Yamaha OPL3-SAx soundcard but have absolutely zero sound
with RH8.0 It worked with RH7.2

The kernel sees the card during bootup as shown in dmesg: -
isapnp: Scanning for PnP cards...
isapnp: Card 'OPL3-SA3 Sound Board'
isapnp: 1 Plug & Play card detected total
speakup:  initialized device: /dev/synth, node (MAJOR 10, MINOR 25)

I then tried to configure the card using the System Settings/Soundcard
Detection utility and it came back with "No soundcards detected"

I then reverted to Windows 98 (under which the soundcard works fine) and
noted the parameters for the card, i/o addresses of 220-22F, 530-537,
388-38F, 330-331, 370-371. IRQ=5, DMA 0 DMA 1.

Back in RH8 I then ran /usr/sbin/sndconfig which only offered me one of
the W98 i/o adresses (530) the others not being compatible with the W98
addresses. Also the DMA was shown as DMA 1 and DMA2.

On clicking the test button it came back with an error message, an error
occurred opening dev/audio.

I downloaded the driver from the OSS, tried to install and got this:-

[root@xxxxx tmp]# ./oss-install
Checking for any previously installed sound drivers... You appear to
have the the kernel level sound driver installed as a loadable
module. Unload it by executing rmmod sound and try installing OSS/Linux

If this error repeats again you probably have the sound driver being
loaded automagically by the kerneld daemon. In this case you should
remove all sound.o files from all subdirectories of /lib/modules in
addition to executing rmmod sound. After that you probably should reboot
the system before trying to install OSS again. Edit /etc/modules.conf
and remove the 'alias sound ...' line in case it exist and replace it by
'alias sound off'.

Also add a line containing 'alias char-major-14 off' to
Am I allowed to do these changes automatically for you (Y/N) ? N

Error: OSS cannot be installed because there is another sound driver
Driver 'sound' has registered the sound device (character major 14) for

You seem to have OSS/Free statically linked into kernel.
You need to reconfigure and reinstall the kernel
with sound support disabled.

[I have not done any of the directions in the OSS application.]

The following is an extract from my system.log file during shutdown.

Nov 27 23:49:19 linux kernel: ad1848/cs4248 codec driver Copyright (C)
by Hannu Savolainen 1993-1996
Nov 27 23:49:19 linux kernel: ad1848: OPL3-SA2 WSS mode detected
Nov 27 23:49:19 linux kernel: ad1848: ISAPnP reports 'OPL3-SA2 WSS mode'
at i/o 0xe80, irq 5, dma 1, 3
Nov 27 23:49:19 linux modprobe: modprobe: Can't locate module
Nov 27 23:49:20 linux modprobe: modprobe: Can't locate module
Nov 27 23:49:23 linux last message repeated 14 times
Nov 27 23:49:27 linux xinetd[1025]: warning: can't get client address:
Transport endpoint is not connected
Nov 27 23:49:29 linux modprobe: modprobe: Can't locate module
Nov 27 23:49:32 linux last message repeated 12 times

This is what is in my /etc/modules.conf file:-

alias sound-slot-0 ad1848
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null 2>&1
 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 |

Where do I go from here? Any help much appreciated.



[Index of Archives]     [Sound Cards]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp Users]     [Yosemite Trails]

  Powered by Linux