[Sound] Re: Re: Crystal sound

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<


Bhatts (dkbhatt@xxxxxxx) said: 
> I ran sndconfig and tried playing sound thru GNOME in the Control Panel. The
> system froze. I went around looking for how to check the settings and found
> /etc/modules.conf. The relevant lines were
> options cs4232 io=0x534 dma=1 dma2=3 irq=5
> I tried changing it to dma2=0 . The system still froze when I tried to play
> a song. Then I found /etc/isapnp.conf and got cracking (I'm but a beginner,
> though)

Does the card show up when you run pnpdump, presumably?

> The system still froze when I played a file.
> I tried loading the modules with the settings:
> modprobe sound
> insmod ad1848
> insmod uart401 io=0x330 irq=9
> insmod opl3 io=0x388
> insmod cs4232 io=0x534 irq=5 dma=1 dma2=3 / 0 (also) synthio=0x388
> synthirq=5 mpuio=0x330 mpuirq=9
> I don't know where to put in IO 0x220

You shouldn't have to; that's the legacy SB compat IO port.

> play [filename]
> It gives the error I wrote about. I tried changing the DMA, but it still
> gives the same error.

Hm, it *could* be a driver bug, I suppose.

> Am I making a mistake during sonfiguration of the card? Should I use
> sndconfig or isapnp or both?

sndconfig uses isapnp if it sees a card.


[Index of Archives]     [Sound Cards]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp Users]     [Yosemite Trails]

  Powered by Linux