Re: [Sound] Re: Crystal sound

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<


I don't understand.

I'm runninng WindowsME/Linux 6.2 on an i686

My BIOS settings for the sound devices are

WSS/SB IRQ = 5 dma = 1,3

My WindowsME settings are

Crystal WDM Audio Codec
DMA = 1
DMA = 3
IRQ = 5
I/O Range = 0534 - 0537
I/O Range = 0388 - 038B
I/O Range = 0220 - 022F

Crystal WDM MPU-401 Compatible
IRQ = 9
I/O = 0330 - 0331

I ran sndconfig and tried playing sound thru GNOME in the Control Panel. The
system froze. I went around looking for how to check the settings and found
/etc/modules.conf. The relevant lines were

options cs4232 io=0x534 dma=1 dma2=3 irq=5

I tried changing it to dma2=0 . The system still froze when I tried to play
a song. Then I found /etc/isapnp.conf and got cracking (I'm but a beginner,
though) I put the settings as:

IRQ = 5
DMA = 1
DMA2 = 3
IO = 0x534
IO2 = 0x388
IO3 = 0x220

IO = 0x120

IO = 0x200

IRQ = 9
IO = 0x330

Then I ran

isapnp /etc/isapnp.conf

The system still froze when I played a file.
I tried loading the modules with the settings:

modprobe sound
insmod ad1848
insmod uart401 io=0x330 irq=9
insmod opl3 io=0x388
insmod cs4232 io=0x534 irq=5 dma=1 dma2=3 / 0 (also) synthio=0x388
synthirq=5 mpuio=0x330 mpuirq=9

I don't know where to put in IO 0x220
cat /proc/interrupts recognised the device(s)
cat /proc/dma recognised the device
cat /proc/ioports also recognised the device

But on rebooting, only ad1848 and opl3 were recognised, though the
interrupts, ioports and dma showed the Crystal Sound.
Also I ran

cat /dev/sndstat

Config options or whatever = 0

The next two, I think "Installed drivers" and "Card config" showed nothing.

MIDI devices
0: MPU-401
Audio devices
0: Crystal Sound (cs4235) duplex

System timers

0: Crystal Sound (cs4235)

I even tried running MAKEDEV -audio

I have no idea whats going on.
When I  'play' a file

play [filename]

It gives the error I wrote about. I tried changing the DMA, but it still
gives the same error.
Am I making a mistake during sonfiguration of the card? Should I use
sndconfig or isapnp or both?

I'm checking up on ALSA to try to configure it that way. I am also reading
up about recompiling the kernel. ALSA guide says if the soundcore module is
loaded I don't need to recompile. So what am I suppose to do :(

My apologies and thanx to all those who read this, more to those who reply!

----- Original Message -----
From: "Bill Nottingham" <notting@xxxxxxxxxx>
To: <sound-list@xxxxxxxxxx>
Sent: Monday, November 18, 2002 10:19 PM
Subject: [Sound] Re: Crystal sound

> Bhatts (dkbhatt@xxxxxxx) said:
> > # play /usr/share/sounds/phone.wav
> >
> > it gives a vague sound and then an error:
> >
> > Sound: DMA (output) timed out - IRQ/DRQ config error?
> > ad1848: auto calibration timed out (3).
> That generally means the IRQ, DMA, IO port, etc. aren't set right.
> Bill
> _______________________________________________
> Sound-list mailing list
> Sound-list@xxxxxxxxxx

[Index of Archives]     [Sound Cards]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp Users]     [Yosemite Trails]

  Powered by Linux