nm256 AV, thinkpad 390 and RH 9.0 : cannot get sound...help !

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<


following instructions on http://linux.oreillynet.com/pub/a/linux/2002/09/19/linuxlaptop.html i have setup up ALSA-0.9rc6 on my IBM thinkpad pentium II 390 with Neomagic 256 AV *NMA2* sound chipset. I carrefully, followed the instructions in the alsa INSTALL file. They all compiled fine, went through the motions, but all resulted in that message when i run modprobe snd-cs4232 :

[root@xxxxxxxxx root]# modprobe snd-cs4232

/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: unresolved symbol schedule_work

/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: insmod /lib/modules/2.4.20-8/kernel/sound/acore/snd.o failed

/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: insmod snd-cs4232 failed

[root@xxxxxxxxx root]#

i got same output even if i try modprobe snd-nm256. Editing modules.conf and rebooting the machine did not improve nothing. Naturally, i did not get any sound to work under linux. I'm running redhat 9.0. I really don't know if this is related to a bug in that ver of ALSA, or something like a conflict interrupt trouble which i don't know and that prevent access to the card. My audio BIOS setting is the following :
SB I/O address : 220
WSS I/O address : 530
adlib I/O address : 388
MPU I/O address : 300
CTRL I/O address : 120
IRQ : 5
joystick : enabled
I also used the DOS based thinkpad configuration utility program called ps2.exe to get more info, it results in :
ADDress : 530
Sbaddress : 220
ADLibaddress : 388
MIDIport : 300
CTRLaddress : 120
IRQ : 5
DMA : 0
Before ALSA i already tried the default Redhat kernel 2.4.20-8 nm256_audio module given by  the installation. However, despite the drivers "correctly" loaded as lsmod command showed, i didn't get audio to play and the RH control volume tool at each attempt warns me that he cannot access to /dev/dsp...
I tried to compile a prior version of alsa which is "alsa-driver-0.5.12". Unfortunately, he refused to compile invoking repeatedly by this error message "slab.h" :

/usr/src/linux-2.4/include/linux/malloc.h:4:2: #error linux/malloc.h is deprecated, use linux/slab.h instead.

Any ideas on what might be the problem and how it could be solved. Specially, the latter one "malloc.h is deprecated..." i meet this message many times when compiling various "old" program source code...
Best regards.

[Index of Archives]     [Sound Cards]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp Users]     [Yosemite Trails]

  Powered by Linux