On Mon, 06 Mar 2023 08:21:07 +1100 "NeilBrown" <neilb@xxxxxxx> wrote: > On Sat, 04 Mar 2023, Song Liu wrote: > > + Jes. > > > > It appeared to me that we can assemble the array if we have any of the > > following: > > 1. Enable CONFIG_BLOCK_LEGACY_AUTOLOAD; > > 2. Have a valid /etc/mdadm.conf; > > 3. Update mdadm to handle this case. (I tried some ugly hacks, which worked > > but weren't clean). > > > > Since we eventually would like to get rid of CONFIG_BLOCK_LEGACY_AUTOLOAD, I > > think we need mdadm to handle this properly. But the logistics might > > be complicated, as > > mdadm are shipped separately. > > > > Jes, what do you think about this? AFAICT, we need to update the logic in > > mdopen.c:create_mddev(). > > mdadm already handles this, but only if > CREATE names=yes > is present in /etc/mdadm.conf Hi, "CREATE names=yes" enforces creation of /dev/md_name arrays instead of /dev/mdXXX. It is a large change for users, too aggressive IMO. It will destroy many setups. To resolve it, we need is to use create_named_array() but respect old naming convention. We already have find_free_devnm(), and we are able to keep consistency because we can create 'mdXXX': /sys/module/md_mod/parameters # echo md125 > new_array /sys/module/md_mod/parameters # ll /sys/block/md125 lrwxrwxrwx 1 root root 0 Mar 7 10:54 /sys/block/md125 -> ../devices/virtual/block/md125 That will require adjustments in mdadm, but I think that we can keep names the same way. I created the test for verification of base creation flows, we can use it to avoid regression: https://git.kernel.org/pub/scm/utils/mdadm/mdadm.git/tree/tests/00createnames Thoughts? BTW. I wanted to get rid of this legacy "create_on_open" from mdadm anyway but never had time to. If you agree, I can proceed with fixing it. Thanks, Mariusz