On Tue, 29 Apr 2008 13:35:34 +1000 NeilBrown <neilb@xxxxxxx> wrote: > + printk_rl(KERN_WARNING "raid5:%s: read error NOT corrected!! " > + "(sector %llu on %s).\n", > + mdname(conf->mddev), > + (unsigned long long)(sh->sector + rdev->data_offset), > + bdn); > else if (atomic_read(&rdev->read_errors) > > conf->max_nr_stripes) > printk(KERN_WARNING > > diff .prev/include/linux/raid/md_k.h ./include/linux/raid/md_k.h > --- .prev/include/linux/raid/md_k.h 2008-04-29 12:25:24.000000000 +1000 > +++ ./include/linux/raid/md_k.h 2008-04-29 12:27:58.000000000 +1000 > @@ -368,6 +368,9 @@ static inline void safe_put_page(struct > if (p) put_page(p); > } > > +#define printk_rl printk_ratelimit() ?: printk (boggle) Isn't this backwards? Should be !printk_ratelimit()? open-coding the printk_ratelimit() at each callsite would be more conventional. -- To unsubscribe from this list: send the line "unsubscribe linux-raid" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html