Re: Crackling Audio in Pulseaudio RTP Stream

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi Chris,
I've checles that, but on archlinux I have speexdsp 1.2.1, but the problem still occurs :(

Any other idea?

On 20/02/2023 12:40, Chris Beat wrote:
On 19/02/2023 20:10, NicoHood wrote:
Hey Sean
as I said I've setup pulseaudio via paprefs. I've enabled the RTP receiver and the sender with a loopback device. Basically I've checked all 4 checkboxes in the paprefs RTP menu.

And as I said, it also happens on the local host itself. I am also receiving (playing) the sound on the device that is the sender, via the loopback functionality. And thatswhy there is no lan/wifi
issue, as it is completely local. But I use LAN anyways everywhere.

@Chris (from the other mail), I am also using puldeaudio 16.1 on ArchLinux, but sadly it does not
fix it for me. :( Maybe you can find the bug report?

I found it, and also figured out again, why it was so difficult to find ... it was *not* directly a pulseaudio bug, but a bug in the libspeexdsp1 library, which also only affected a minority use case
involving e.g. Raspberries (if I understood correctly):

I followed the advise of the Debian maintainer at the end of the bug report:

"Version: 1.2.0-1

I believe this bug is fixed with latest unpatched speexdsp upload.

Boyuan Yang"

and installed the latest version of "libspeexdsp1" and I *think* that solved the problem for me.

For reference ... in the debian bug report, they are referring to this commit:

... you will problably have to check when/if this was incorporated into your distribution's version of the library ... assuming that you ARE hit by the same bug as me ... could as well be something
completely different.

On 19/02/2023 07:46, Sean Greenslade wrote:
On Sat, Feb 18, 2023 at 08:44:21PM +0100, NicoHood wrote:
Hey Guys,
I am using pulseaudio for years now, but since Version 14, maybe 15 there is a crackling in the rtp stream. I've setup RTP just with paprefs, enable the
sender and local receiver on a separate audio device.

I know that I am reporting this really late and the bug is there for some years now. I hoped this gets eventually fixed, but it did not. I am using
the latest archlinux pulseaudio.

Are you guys aware of the issue, does it also happen to you? It is just a tiny crackling, but you can hear in on good audio boxes. It sound a bit like
the vinyl sound, just not so often. You can hear it on the sender via
loopback and on all other receivers as well.

Can you describe your setup in more detail? It's unclear if you're using
pulseaudio as the RTP sender, RTP receiver, or both.

Occasional audible crackling is usually due to buffer underruns. Are
your RTP streams going over a wireless network? If so, have you tried
increasing the jitter buffer size on the receiver?


[Index of Archives]     [Linux Audio Users]     [AMD Graphics]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux