> NFPROTO_* constants were usually equal to PF_* constants but it is not > necessary and it will waste less memory if we don't do so > (see commit 7e9c6e > "netfilter: Introduce NFPROTO_* constants") ... > > static struct nf_hook_ops dnrmg_ops __read_mostly = { > .hook = dnrmg_hook, > - .pf = PF_DECnet, > + .pf = NFPROTO_DECNET, > .hooknum = NF_DN_ROUTE, > .priority = NF_DN_PRI_DNRTMSG, > }; Might it be worth renaming the .pf member to (say) .nfproto to help avoid confusion? David -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html