On Tuesday 2008-04-08 18:14, Patrick McHardy wrote: > > Small suggestion for improvement (don't worry, your series > is fine :)): the best ordering for all these patches would > have been: > > Set 1: boolean conversions > Set 2: length match (shouldn't have dependencies) > Set 3: recent match (also shouldn't have dependencies) > Set 4: prefix table > Set 5: TCPMSS target > Set 6: ARP-tables patches You would not believe it, but it was set-ordered. YMMV what makes up a set, though. (reverse order as git-forest and gitk do) Group 7: independent things (i think you have b8a already) Depends on: Nothing. ╟ [NETFILTER]: nf_nat: autoload IPv4 connection tracking──(b8a26c9) ╟ [NETFILTER]: Deploy a prefix_length-to-network mask mapping table──(f6984b5) ╟ [NETFILTER]: Collapse tcpmss_reverse_mtu{4,6} into one function──(b98252d) Group 6: Ebtables. Depends on: Nothing. ╟ [NETFILTER]: Make Ebtables use Xtables infrastructure──(00e0636) Group 5: Arptables. Depends on Group 4. ╟ [NETFILTER]: Give AF-independent extensions an arpt_ alias──(2974d08) Group 4: Xtables basement. Depends on: Nothing. ╟ [NETFILTER]: Implement AF_UNSPEC as a wildcard for extensions──(cd37935) ╟ [NETFILTER]: rename NF_ARP to NFPROTO_ARP and assign a non-clashing value──(2a Group 3: xt_recent. Depends on: Nothing. ╟ [NETFILTER]: xt_recent: IPv6 support──(e6fb817) ╟ [NETFILTER]: Rename ipt_recent to xt_recent──(5130e28) Group 2: xt_length. Depends on: Nothing. ╟ [NETFILTER]: xt_length match, revision 1──(9e46f22) Group 1: Bools, Consts, Cleanups. Depends on: Nothing. ╟ [NETFILTER]: Replace NF_CT_DUMP_TUPLE macro indrection by function call──(f73c ╟ [NETFILTER]: const annotations in nf_conntrack_{sctp,dccp}, nf_nat_proto_gre── ╟ [NETFILTER]: Use bool type in nf_nat_proto──(2c53bda) ╟ [NETFILTER]: Use bool type in struct nf_conntrack_tuple.h──(aca885c) ╟ [NETFILTER]: Use unsigned types for hooknum and pf vars──(91d8746) ╟ [NETFILTER]: Use bool type in struct nf_conntrack_l4proto──(37930da) ╟ [NETFILTER]: Use bool type in struct nf_conntrack_l3proto──(67629b2) > This way each logical set of changes can be discussed > seperately. I'd also send things that need additional > userspace-patches (like length) as kernel patch 1-n + > iptables patch 1-n, but closely together. > Invent house numbering? [patch 12/xx] xt_length [patch 12a/xx] xt_length userspace [patch 13/xx] xt_foobar (kernel only thing) [patch 14/xx] xt_bazzzz [patch 14a/xx] .. don't think git likes that :p -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html