Jan Engelhardt wrote:
Those other 8 loose mails (git-send-email has too many flags to get it right every time) make up the second group (of two) of kernel patches. ⋮ ╟ [NETFILTER]: Rename ipt_recent to xt_recent ╟ [NETFILTER]: xt_recent: IPv6 support ╟ [NETFILTER]: rename NF_ARP to NFPROTO_ARP and assign a non-clashingvalue ╟ [NETFILTER]: Implement AF_UNSPEC as a wildcard for extensions ╟ [NETFILTER]: Give AF-independent extensions an arpt_ alias ╟ [NETFILTER]: Make Ebtables use Xtables infrastructure ╟ [NETFILTER]: Collapse tcpmss_reverse_mtu{4,6} into one function ╟ [NETFILTER]: Deploy a prefix_length-to-network mask mapping table ⋮ ╙─[master]
Small suggestion for improvement (don't worry, your series is fine :)): the best ordering for all these patches would have been: Set 1: boolean conversions Set 2: length match (shouldn't have dependencies) Set 3: recent match (also shouldn't have dependencies) Set 4: prefix table Set 5: TCPMSS target Set 6: ARP-tables patches This way each logical set of changes can be discussed seperately. I'd also send things that need additional userspace-patches (like length) as kernel patch 1-n + iptables patch 1-n, but closely together. -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html