On 07/14/2010 08:40 PM, Florian Fainelli wrote: > Hi Wolfgang, > > 2010/7/14 Wolfgang Grandegger <wg@xxxxxxxxxxxxxx>: >> From: Wolfgang Grandegger <wg@xxxxxxx> >> >> This patch adds basic support for the General Purpose Router (GPR) >> board from Trapeze ITS. >> >> Signed-off-by: Wolfgang Grandegger <wg@xxxxxxx> > [snip] > >> + >> +/* >> + * LEDs >> + */ >> +static struct gpio_led gpr_gpio_leds[] = { >> + { /* green */ >> + .name = "green", >> + .gpio = 4, >> + .active_low = 1, >> + .default_trigger = "none", >> + }, >> + { /* red */ >> + .name = "red", >> + .gpio = 5, >> + .active_low = 1, >> + .default_trigger = "none", >> + } >> +}; > > Should be "gpr:green" and "gpr:red" respectively to follow the Linux > LEDs class naming conventions. The default trigger is superfluous, Will be fixed. > however it would make sense to have the green led be associated with > the "default-on" trigger. Otherwise, it looks very good. I just played with various default triggers. None of them is needed and I will remove it. In the board setup code, the LEDs are toggled and therefore I do not want to define a "default-on". Thanks, Wolfgang.