Hi Wolfgang, 2010/7/14 Wolfgang Grandegger <wg@xxxxxxxxxxxxxx>: > From: Wolfgang Grandegger <wg@xxxxxxx> > > This patch adds basic support for the General Purpose Router (GPR) > board from Trapeze ITS. > > Signed-off-by: Wolfgang Grandegger <wg@xxxxxxx> [snip] > + > +/* > + * LEDs > + */ > +static struct gpio_led gpr_gpio_leds[] = { > + { /* green */ > + .name = "green", > + .gpio = 4, > + .active_low = 1, > + .default_trigger = "none", > + }, > + { /* red */ > + .name = "red", > + .gpio = 5, > + .active_low = 1, > + .default_trigger = "none", > + } > +}; Should be "gpr:green" and "gpr:red" respectively to follow the Linux LEDs class naming conventions. The default trigger is superfluous, however it would make sense to have the green led be associated with the "default-on" trigger. Otherwise, it looks very good. -- Florian