On 09/27/2017 07:49 AM, Petr Mladek wrote: > On Thu 2017-08-31 10:53:53, Joe Lawrence wrote: >> Log a few kernel debug messages at the beginning of the following livepatch >> transition functions: >> >> klp_complete_transition() >> klp_cancel_transition() >> klp_init_transition() >> klp_reverse_transition() >> >> Also update the log notice message in klp_start_transition() for similar >> verbiage as the above messages. >> >> Suggested-by: Josh Poimboeuf <jpoimboe@xxxxxxxxxx> >> Signed-off-by: Joe Lawrence <joe.lawrence@xxxxxxxxxx> >> --- >> kernel/livepatch/transition.c | 18 +++++++++++++++++- >> 1 file changed, 17 insertions(+), 1 deletion(-) >> >> diff --git a/kernel/livepatch/transition.c b/kernel/livepatch/transition.c >> index 53887f0bca10..3d44a3cf27be 100644 >> --- a/kernel/livepatch/transition.c >> +++ b/kernel/livepatch/transition.c >> @@ -82,6 +82,10 @@ static void klp_complete_transition(void) >> unsigned int cpu; >> bool immediate_func = false; >> >> + pr_debug("'%s': completing %s transition\n", >> + klp_transition_patch->mod->name, >> + klp_target_state == KLP_PATCHED ? "patching" : "unpatching"); >> + >> if (klp_target_state == KLP_UNPATCHED) { >> /* >> * All tasks have transitioned to KLP_UNPATCHED so we can now >> @@ -163,6 +167,9 @@ void klp_cancel_transition(void) >> if (WARN_ON_ONCE(klp_target_state != KLP_PATCHED)) >> return; >> >> + pr_debug("'%s': canceling transition, unpatching\n", > > This sentence is a bit confusing. It is related to the Mirek's concern > about that the following message would be "completing unpatching transition". > > What about using something like: > > pr_debug("'%s': canceling patching transition, going to unpatch\n", > > > Best Regards, > Petr Yeah, what I had was more of a comma splice for brevity... no problem adopting a clearer wording as you suggested. Thanks -- Joe -- To unsubscribe from this list: send the line "unsubscribe live-patching" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html